youtube_native_player 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 74

youtube_native_player #

A new Flutter plugin.

Getting Started #

This project is a starting point for a Flutter plug-in package, a specialized package that includes platform-specific implementation code for Android and/or iOS.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

0.0.1 #

  • TODO: Describe initial release.


youtube_native_player_example #

Demonstrates how to use the youtube_native_player plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  youtube_native_player: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:youtube_native_player/youtube_native_player.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/ios/youtube_native_player_ios.dart. (-2.96 points)

Analysis of lib/ios/youtube_native_player_ios.dart reported 6 hints, including:

line 47 col 8: The value of the field '_videoEndedCalled' isn't used.

line 51 col 3: Prefer using /// for doc comments.

line 61 col 8: This method overrides a method annotated as @mustCallSuper in 'State', but doesn't invoke the overridden method.

line 73 col 3: Prefer using /// for doc comments.

line 200 col 3: Prefer using /// for doc comments.

Fix lib/ios/video_orientations.dart. (-0.50 points)

Analysis of lib/ios/video_orientations.dart reported 1 hint:

line 1 col 8: Unused import: 'package:flutter/material.dart'.

Format lib/android/constrant.dart.

Run flutter format to format lib/android/constrant.dart.

Fix additional 12 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/android/controls_color.dart (Run flutter format to format lib/android/controls_color.dart.)
  • lib/android/duration_range.dart (Run flutter format to format lib/android/duration_range.dart.)
  • lib/android/video_player.dart (Run flutter format to format lib/android/video_player.dart.)
  • lib/android/video_player_controller.dart (Run flutter format to format lib/android/video_player_controller.dart.)
  • lib/android/video_player_value.dart (Run flutter format to format lib/android/video_player_value.dart.)
  • lib/android/video_progress_colors.dart (Run flutter format to format lib/android/video_progress_colors.dart.)
  • lib/android/video_progress_indicator.dart (Run flutter format to format lib/android/video_progress_indicator.dart.)
  • lib/android/youtube_native_player_android.dart (Run flutter format to format lib/android/youtube_native_player_android.dart.)
  • lib/constants/youtube_native_player_constant.dart (Run flutter format to format lib/constants/youtube_native_player_constant.dart.)
  • lib/controls.dart (Run flutter format to format lib/controls.dart.)
  • lib/generated/i18n.dart (Run flutter format to format lib/generated/i18n.dart.)
  • lib/youtube_native_player.dart (Run flutter format to format lib/youtube_native_player.dart.)

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
share ^0.6.1 0.6.3
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies