xstate_fsm 0.0.1

  • Readme
  • Changelog
  • Installing
  • new54

A dart version of the minimal XState version of a finite state machine.

0.0.1 #

  • First testable and working version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  xstate_fsm: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:xstate_fsm/xstate_fsm.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
20
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Mar 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health issues and suggestions

Document public APIs. (-0.25 points)

153 out of 157 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/xstate_fsm.dart. (-4.89 points)

Analysis of lib/xstate_fsm.dart reported 10 hints, including:

line 10 col 10: Don't type annotate initializing formals.

line 26 col 23: Don't type annotate initializing formals.

line 115 col 9: Don't type annotate initializing formals.

line 115 col 27: Don't type annotate initializing formals.

line 198 col 13: Use isNotEmpty for Iterables and Maps.

Maintenance suggestions

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and xstate_fsm.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
equatable ^1.1.1 1.1.1
Transitive dependencies
collection 1.14.12
meta 1.1.8
Dev dependencies
test ^1.14.0