xftts_fluttify 0.1.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 47

Logo

讯飞 TTS语音合成组件 #

pub package CI

Dart接口基于Fluttify编译器生成. dartdoc接口文档. CHANGELOG.

技术支持 #

Fluttify网站 #

  • Fluttify编译器自助服务fluttify.com网站已上线, 欢迎各位来试用, 目前网站仍然处于早期阶段, 如果有什么建议可以在技术支持中提issue.
  • 如何使用网站?
    1. 使用github账号登录网站, 我需要知道是谁在使用我的网站;
    2. 填写原生SDK相关的信息, 填写maven坐标和cocoapods名称的时候会进行联网自动补全;
    3. 提交请求, 目前默认获取目标SDK的最新版本来生成插件;
    4. 请求完成后会往github账号关联的邮箱地址发一份邮件, 产物插件便在邮件的附件中;
  • 网站前端使用flutter for web编写(目前产物可能会比较大, 随着flutter官方的优化这些问题会逐步改善), 部署在github pages上, 所以首次访问可能会异常的慢, 请耐心等待或者多试几次.

接外包 #

本人承接外包项目(地图类app优先), 有意者请联系qq 382146139.

DEMO 与 社区 #

DemoQQ群
扫描二维码
或者
点击下载
加入QQ群讨论 <br/>

安装:

dependencies:
  flutter:
    sdk: flutter
  xftts_fluttify: ^x.x.x

导入:

import 'package:xftts_fluttify/xftts_fluttify.dart';

使用:

/// 初始化 
await XfTTS.init('你的appid');
/// 如果你觉得引擎的日志太多, 可以关闭Fluttify引擎的日志
await enableFluttifyLog(false); // 关闭log

/// 创建合成器对象
Synthesizer synthesizer = await XfTTS.createSynthesizer();
/// 开始语音
await synthesizer.startSpeaking('你要说的话');
/// 暂停语音
await synthesizer.pauseSpeaking();
/// 恢复语音
await synthesizer.resumeSpeaking();
/// 停止语音
await synthesizer.stopSpeaking();
/// 释放资源
await synthesizer.destroy();

iOS Info.plist配置:

<key>NSMicrophoneUsageDescription</key>
<string></string>
<key>NSLocationUsageDescription</key>
<string></string>
<key>NSLocationAlwaysUsageDescription</key>
<string></string>
<key>NSContactsUsageDescription</key>
<string></string>

版本规划 #

版本的语义化 #

- +版本号迭代表示引擎更新,完善引擎能力以及修复引擎bug;
- 小版本号迭代表示无破坏性更新, 包括功能增加和bug修复;
- 次版本号迭代表示有破坏性更新, 包括但不限于接口改动, 类名改动等;
- 主版本号迭代表示底层高德SDK更换;
微信支持支付宝支持

LICENSE #

Copyright 2020 yohom

Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at

http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.

0.1.2 #

  • roll engine #9bdbcc15

0.1.1 #

  • docs: 优化README

0.1.0 #

  • 首个可以使用的版本

0.0.1 #

  • feat: 初始版本 包含基本接口

example/lib/main.dart

import 'package:decorated_flutter/decorated_flutter.dart';
import 'package:flutter/material.dart';
import 'package:xftts_fluttify/xftts_fluttify.dart';

void main() {
  runApp(MyApp());
  // 此 appid 有效期至 2020-06-29, 请自行到讯飞官网申请appid, 然后联系 yohombao@qq.com 生成与appid匹配的插件
  XfTTS.init('5e82d068');
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  final _controller = TextEditingController(text: '哈哈哈');
  Synthesizer _synthesizer;

  @override
  void initState() {
    super.initState();
    XfTTS.createSynthesizer().then((it) => _synthesizer = it);
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        resizeToAvoidBottomInset: false,
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: DecoratedColumn(
          mainAxisAlignment: MainAxisAlignment.center,
          padding: EdgeInsets.all(kSpaceBig),
          children: <Widget>[
            TextField(controller: _controller),
            SPACE_BIG_VERTICAL,
            RaisedButton(
              onPressed: () {
                _synthesizer?.startSpeaking(_controller.text);
              },
              child: Text('开始说话'),
            ),
            RaisedButton(
              onPressed: () {
                _synthesizer?.pauseSpeaking();
              },
              child: Text('暂停说话'),
            ),
            RaisedButton(
              onPressed: () {
                _synthesizer?.resumeSpeaking();
              },
              child: Text('继续说话'),
            ),
            RaisedButton(
              onPressed: () {
                _synthesizer?.stopSpeaking();
              },
              child: Text('停止说话'),
            ),
          ],
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  xftts_fluttify: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:xftts_fluttify/xftts_fluttify.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
85
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Jul 11, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:xftts_fluttify/xftts_fluttify.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:xftts_fluttify/xftts_fluttify.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:xftts_fluttify/xftts_fluttify.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:xftts_fluttify/xftts_fluttify.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • xftts_fluttify that is a package requiring null.

Health suggestions

Fix lib/src/facade/xftts.dart. (-0.50 points)

Analysis of lib/src/facade/xftts.dart reported 1 hint:

line 47 col 15: The declaration '_' isn't referenced.

Format lib/src/android/com/iflytek/cloud/DataDownloader.g.dart.

Run flutter format to format lib/src/android/com/iflytek/cloud/DataDownloader.g.dart.

Format lib/src/android/com/iflytek/cloud/DataUploader.g.dart.

Run flutter format to format lib/src/android/com/iflytek/cloud/DataUploader.g.dart.

Fix additional 138 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/android/com/iflytek/cloud/ErrorCode.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/ErrorCode.g.dart.)
  • lib/src/android/com/iflytek/cloud/EvaluatorListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/EvaluatorListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/EvaluatorResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/EvaluatorResult.g.dart.)
  • lib/src/android/com/iflytek/cloud/FaceDetector.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/FaceDetector.g.dart.)
  • lib/src/android/com/iflytek/cloud/FaceRequest.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/FaceRequest.g.dart.)
  • lib/src/android/com/iflytek/cloud/GrammarListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/GrammarListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/IdentityListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/IdentityListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/IdentityResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/IdentityResult.g.dart.)
  • lib/src/android/com/iflytek/cloud/IdentityVerifier.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/IdentityVerifier.g.dart.)
  • lib/src/android/com/iflytek/cloud/InitListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/InitListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/LexiconListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/LexiconListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/RecognizerListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/RecognizerListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/RecognizerResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/RecognizerResult.g.dart.)
  • lib/src/android/com/iflytek/cloud/RequestListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/RequestListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/Setting.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/Setting.g.dart.)
  • lib/src/android/com/iflytek/cloud/Setting/LOG_LEVEL.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/Setting/LOG_LEVEL.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeakerVerifier.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeakerVerifier.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechConstant.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechConstant.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechError.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechError.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechEvaluator.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechEvaluator.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechEvent.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechEvent.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechRecognizer.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechRecognizer.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechSynthesizer.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechSynthesizer.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechTranscripter.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechTranscripter.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechUnderstander.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechUnderstander.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechUnderstanderListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechUnderstanderListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/SpeechUtility.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SpeechUtility.g.dart.)
  • lib/src/android/com/iflytek/cloud/SynthesizerListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/SynthesizerListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/TextUnderstander.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/TextUnderstander.g.dart.)
  • lib/src/android/com/iflytek/cloud/TextUnderstanderListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/TextUnderstanderListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/TranscripterListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/TranscripterListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/TranscripterResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/TranscripterResult.g.dart.)
  • lib/src/android/com/iflytek/cloud/UnderstanderResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/UnderstanderResult.g.dart.)
  • lib/src/android/com/iflytek/cloud/VerifierListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/VerifierListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/VerifierResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/VerifierResult.g.dart.)
  • lib/src/android/com/iflytek/cloud/Version.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/Version.g.dart.)
  • lib/src/android/com/iflytek/cloud/VoiceWakeuper.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/VoiceWakeuper.g.dart.)
  • lib/src/android/com/iflytek/cloud/WakeuperListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/WakeuperListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/WakeuperResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/WakeuperResult.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/ist/AudioAccessor.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/ist/AudioAccessor.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/ist/AudioAccessor/AudioKeys.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/ist/AudioAccessor/AudioKeys.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/ist/IstSession.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/ist/IstSession.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/AESUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/AESUtil.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/AppInfoUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/AppInfoUtil.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/Base64.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/Base64.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/Config.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/Config.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/DataLogger.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/DataLogger.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/DataUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/DataUtil.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/Encrypter.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/Encrypter.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/FileDownloader.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/FileDownloader.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/FuncAdapter.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/FuncAdapter.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/FuncAdapterSdk10.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/FuncAdapterSdk10.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/HttpRequest.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/HttpRequest.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/HttpRequest/HttpRequestListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/HttpRequest/HttpRequestListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/NetworkUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/NetworkUtil.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/RSAUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/RSAUtil.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/SDCardHelper.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/SDCardHelper.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/UniqueIDUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/UniqueIDUtil.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/http/HttpDownloadImpl.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/http/HttpDownloadImpl.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/http/HttpDownloadListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/http/HttpDownloadListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/http/HttpTransListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/http/HttpTransListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/log/DebugLog.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/log/DebugLog.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/log/DebugLog/LOG_LEVEL.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/log/DebugLog/LOG_LEVEL.g.dart.)
  • lib/src/android/com/iflytek/cloud/msc/util/log/PerfLogger.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/msc/util/log/PerfLogger.g.dart.)
  • lib/src/android/com/iflytek/cloud/record/PcmRecorder.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/record/PcmRecorder.g.dart.)
  • lib/src/android/com/iflytek/cloud/record/PcmRecorder/PcmRecordListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/record/PcmRecorder/PcmRecordListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/resource/Resource.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/resource/Resource.g.dart.)
  • lib/src/android/com/iflytek/cloud/ui/RecognizerDialogListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/ui/RecognizerDialogListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/Accelerometer.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/Accelerometer.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/Accelerometer/CLOCKWISE_ANGLE.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/Accelerometer/CLOCKWISE_ANGLE.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/AudioDetector.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/AudioDetector.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/AudioDetector/DetectorResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/AudioDetector/DetectorResult.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/ContactManager.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/ContactManager.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/ContactManager/ContactListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/ContactManager/ContactListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/FileDownloadListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/FileDownloadListener.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/ResourceUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/ResourceUtil.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/ResourceUtil/RESOURCE_TYPE.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/ResourceUtil/RESOURCE_TYPE.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/UserWords.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/UserWords.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/VerifierUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/VerifierUtil.g.dart.)
  • lib/src/android/com/iflytek/cloud/util/VolumeUtil.g.dart (Run flutter format to format lib/src/android/com/iflytek/cloud/util/VolumeUtil.g.dart.)
  • lib/src/android/com/iflytek/idata/extension/IFlyCollectorExt.g.dart (Run flutter format to format lib/src/android/com/iflytek/idata/extension/IFlyCollectorExt.g.dart.)
  • lib/src/android/com/iflytek/msc/AIMIC.g.dart (Run flutter format to format lib/src/android/com/iflytek/msc/AIMIC.g.dart.)
  • lib/src/android/com/iflytek/msc/AIMIC/Listener.g.dart (Run flutter format to format lib/src/android/com/iflytek/msc/AIMIC/Listener.g.dart.)
  • lib/src/android/com/iflytek/msc/MSC.g.dart (Run flutter format to format lib/src/android/com/iflytek/msc/MSC.g.dart.)
  • lib/src/android/com/iflytek/msc/MSCSessionInfo.g.dart (Run flutter format to format lib/src/android/com/iflytek/msc/MSCSessionInfo.g.dart.)
  • lib/src/android/com/iflytek/msc/MetaVAD.g.dart (Run flutter format to format lib/src/android/com/iflytek/msc/MetaVAD.g.dart.)
  • lib/src/android/com/iflytek/msc/MetaVAD/Instance.g.dart (Run flutter format to format lib/src/android/com/iflytek/msc/MetaVAD/Instance.g.dart.)
  • lib/src/android/com/iflytek/msc/VAD.g.dart (Run flutter format to format lib/src/android/com/iflytek/msc/VAD.g.dart.)
  • lib/src/android/com/iflytek/msc/VAD/VadData.g.dart (Run flutter format to format lib/src/android/com/iflytek/msc/VAD/VadData.g.dart.)
  • lib/src/android/com/iflytek/speech/ISpeechModule.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/ISpeechModule.g.dart.)
  • lib/src/android/com/iflytek/speech/RecognizerResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/RecognizerResult.g.dart.)
  • lib/src/android/com/iflytek/speech/SpeakerVerifierAidl.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/SpeakerVerifierAidl.g.dart.)
  • lib/src/android/com/iflytek/speech/SpeakerVerifierAidl/DownloadListener.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/SpeakerVerifierAidl/DownloadListener.g.dart.)
  • lib/src/android/com/iflytek/speech/SpeakerVerifierAidl/PassWord.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/SpeakerVerifierAidl/PassWord.g.dart.)
  • lib/src/android/com/iflytek/speech/SpeechComponent.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/SpeechComponent.g.dart.)
  • lib/src/android/com/iflytek/speech/SpeechRecognizerAidl.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/SpeechRecognizerAidl.g.dart.)
  • lib/src/android/com/iflytek/speech/SpeechSynthesizerAidl.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/SpeechSynthesizerAidl.g.dart.)
  • lib/src/android/com/iflytek/speech/SpeechUnderstanderAidl.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/SpeechUnderstanderAidl.g.dart.)
  • lib/src/android/com/iflytek/speech/TextUnderstanderAidl.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/TextUnderstanderAidl.g.dart.)
  • lib/src/android/com/iflytek/speech/UnderstanderResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/UnderstanderResult.g.dart.)
  • lib/src/android/com/iflytek/speech/UtilityConfig.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/UtilityConfig.g.dart.)
  • lib/src/android/com/iflytek/speech/VerifierResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/VerifierResult.g.dart.)
  • lib/src/android/com/iflytek/speech/Version.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/Version.g.dart.)
  • lib/src/android/com/iflytek/speech/VoiceWakeuperAidl.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/VoiceWakeuperAidl.g.dart.)
  • lib/src/android/com/iflytek/speech/WakeuperResult.g.dart (Run flutter format to format lib/src/android/com/iflytek/speech/WakeuperResult.g.dart.)
  • lib/src/android/constants.g.dart (Run flutter format to format lib/src/android/constants.g.dart.)
  • lib/src/android/type_op.g.dart (Run flutter format to format lib/src/android/type_op.g.dart.)
  • lib/src/ios/IFlyAudioSession.g.dart (Run flutter format to format lib/src/ios/IFlyAudioSession.g.dart.)
  • lib/src/ios/IFlyDataUploader.g.dart (Run flutter format to format lib/src/ios/IFlyDataUploader.g.dart.)
  • lib/src/ios/IFlyDebugLog.g.dart (Run flutter format to format lib/src/ios/IFlyDebugLog.g.dart.)
  • lib/src/ios/IFlyEngineMode.g.dart (Run flutter format to format lib/src/ios/IFlyEngineMode.g.dart.)
  • lib/src/ios/IFlyISVDelegate.g.dart (Run flutter format to format lib/src/ios/IFlyISVDelegate.g.dart.)
  • lib/src/ios/IFlyISVRecognizer.g.dart (Run flutter format to format lib/src/ios/IFlyISVRecognizer.g.dart.)
  • lib/src/ios/IFlyPcmRecorderDelegate.g.dart (Run flutter format to format lib/src/ios/IFlyPcmRecorderDelegate.g.dart.)
  • lib/src/ios/IFlyRecognizerView.g.dart (Run flutter format to format lib/src/ios/IFlyRecognizerView.g.dart.)
  • lib/src/ios/IFlyRecognizerViewDelegate.g.dart (Run flutter format to format lib/src/ios/IFlyRecognizerViewDelegate.g.dart.)
  • lib/src/ios/IFlyResourceUtil.g.dart (Run flutter format to format lib/src/ios/IFlyResourceUtil.g.dart.)
  • lib/src/ios/IFlySetting.g.dart (Run flutter format to format lib/src/ios/IFlySetting.g.dart.)
  • lib/src/ios/IFlySpeechConstant.g.dart (Run flutter format to format lib/src/ios/IFlySpeechConstant.g.dart.)
  • lib/src/ios/IFlySpeechError.g.dart (Run flutter format to format lib/src/ios/IFlySpeechError.g.dart.)
  • lib/src/ios/IFlySpeechEvaluator.g.dart (Run flutter format to format lib/src/ios/IFlySpeechEvaluator.g.dart.)
  • lib/src/ios/IFlySpeechEvaluatorDelegate.g.dart (Run flutter format to format lib/src/ios/IFlySpeechEvaluatorDelegate.g.dart.)
  • lib/src/ios/IFlySpeechEventType.g.dart (Run flutter format to format lib/src/ios/IFlySpeechEventType.g.dart.)
  • lib/src/ios/IFlySpeechPlusServiceType.g.dart (Run flutter format to format lib/src/ios/IFlySpeechPlusServiceType.g.dart.)
  • lib/src/ios/IFlySpeechRecognizer.g.dart (Run flutter format to format lib/src/ios/IFlySpeechRecognizer.g.dart.)
  • lib/src/ios/IFlySpeechRecognizerDelegate.g.dart (Run flutter format to format lib/src/ios/IFlySpeechRecognizerDelegate.g.dart.)
  • lib/src/ios/IFlySpeechSynthesizer.g.dart (Run flutter format to format lib/src/ios/IFlySpeechSynthesizer.g.dart.)
  • lib/src/ios/IFlySpeechSynthesizerDelegate.g.dart (Run flutter format to format lib/src/ios/IFlySpeechSynthesizerDelegate.g.dart.)
  • lib/src/ios/IFlySpeechUtility.g.dart (Run flutter format to format lib/src/ios/IFlySpeechUtility.g.dart.)
  • lib/src/ios/IFlySpeechplusDelegate.g.dart (Run flutter format to format lib/src/ios/IFlySpeechplusDelegate.g.dart.)
  • lib/src/ios/IFlyUserWords.g.dart (Run flutter format to format lib/src/ios/IFlyUserWords.g.dart.)
  • lib/src/ios/IFlyVoiceWakeuper.g.dart (Run flutter format to format lib/src/ios/IFlyVoiceWakeuper.g.dart.)
  • lib/src/ios/IFlyVoiceWakeuperDelegate.g.dart (Run flutter format to format lib/src/ios/IFlyVoiceWakeuperDelegate.g.dart.)
  • lib/src/ios/LOG_LEVEL.g.dart (Run flutter format to format lib/src/ios/LOG_LEVEL.g.dart.)
  • lib/src/ios/constants.g.dart (Run flutter format to format lib/src/ios/constants.g.dart.)
  • lib/src/ios/functions.g.dart (Run flutter format to format lib/src/ios/functions.g.dart.)
  • lib/src/ios/type_op.g.dart (Run flutter format to format lib/src/ios/type_op.g.dart.)

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (foundation_fluttify).

The package description is too short. (-5 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.6.0 <3.0.0
flutter 0.0.0
foundation_fluttify ^0.7.0 0.7.3 0.8.10
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test