wormhole_generator 1.0.0

Changelog #

1.0.0 #

  • Created WormHole

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wormhole_generator: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wormhole_generator/builder.dart';
import 'package:wormhole_generator/generated/i18n.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
86
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
40
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:wormhole_generator/builder.dart, package:wormhole_generator/src/generator.dart, package:wormhole/platform_annotations.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:wormhole_generator/builder.dart, package:wormhole_generator/src/generator.dart, package:wormhole/platform_annotations.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:wormhole_generator/builder.dart, package:wormhole_generator/src/generator.dart, package:wormhole/platform_annotations.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:wormhole_generator/builder.dart, package:wormhole_generator/src/generator.dart, package:wormhole/platform_annotations.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [wormhole_generator] that is in a package requiring null.

Package not compatible with SDK flutter

Because it is not compatible with any of the supported runtimes: flutter-native, flutter-web

Package not compatible with runtime flutter-native on android

Because of the import of dart:mirrors via the import chain package:wormhole_generator/builder.dartpackage:wormhole_generator/src/generator.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/type_checker.dartdart:mirrors

Package not compatible with runtime flutter-native on ios

Because of the import of dart:mirrors via the import chain package:wormhole_generator/builder.dartpackage:wormhole_generator/src/generator.dartpackage:source_gen/source_gen.dartpackage:source_gen/src/type_checker.dartdart:mirrors

Health suggestions

Fix lib/src/generator.dart. (-13.09 points)

Analysis of lib/src/generator.dart reported 28 hints, including:

line 34 col 3: Name non-constant identifiers using lowerCamelCase.

line 99 col 28: 'type' is deprecated and shouldn't be used.

line 101 col 3: Prefer using /// for doc comments.

line 110 col 3: Prefer using /// for doc comments.

line 127 col 3: Prefer using /// for doc comments.

Fix lib/src/generator_helper.dart. (-1 points)

Analysis of lib/src/generator_helper.dart reported 2 hints:

line 4 col 8: Unused import: 'package:code_builder/code_builder.dart'.

line 73 col 15: 'name' is deprecated and shouldn't be used. Check element, or use getDisplayString().

Format lib/generated/i18n.dart.

Run flutter format to format lib/generated/i18n.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and wormhole_generator.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
built_collection ^4.2.0 4.3.2
code_builder ^3.2.0 3.3.0
flutter 0.0.0
source_gen ^0.9.4+2 0.9.5
wormhole ^1.0.0 1.0.0
Transitive dependencies
_fe_analyzer_shared 5.0.0
analyzer 0.39.12
args 1.6.0
async 2.4.2
build 1.3.0
built_value 7.1.0
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
csslib 0.16.1
dart_style 1.3.6
fixnum 0.10.11
glob 1.2.0
html 0.14.0+3
js 0.6.2
logging 0.11.4
matcher 0.12.8
meta 1.1.8 1.2.1
node_interop 1.1.1
node_io 1.1.1
package_config 1.9.3
path 1.7.0
pedantic 1.9.0 1.9.1
pub_semver 1.4.4
quiver 2.1.3
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6 1.2.0
vector_math 2.0.8
watcher 0.9.7+15
yaml 2.2.1
Dev dependencies
flutter_test
mock_web_server ^4.1.1
resource any
source_gen_test any
test any