woosignal_stripe 0.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 78

woosignal_stripe #

Official WooSignal Stripe package

Add Stripe to your WooSignal WooCommerce App.

Note. this is only for WooSignal apps that want to use Stripe.

For help getting started with WooSignal, view our online documentation, which offers a more detail guide.

0.0.2 #

  • Bug fixes

0.0.1 #

  • initial release

example/README.md

flutter_stripe_payment_example #

Demonstrates how to use the flutter_stripe_payment plugin.

Setup Stripe Environment #

FlutterStripePayment.setStripeSettings(
        appConfig.values.stripePublishableKey,
        appConfig.values.applePayMerchantId);

Show Payment Form #

var paymentMethodId = await FlutterStripePayment.addPaymentMethod();

Create Payment Intent On Server #

var intent = PaymentIntent();
    intent.amount = widget.order.cart.total;
    intent.isManual = true;
    intent.isConfirmed = false;
    intent.paymentMethodId = paymentMethodId;
    intent.currency = "usd";
    intent.isOnSession = true;
    intent.isSuccessful = false;
    intent.statementDescriptor = "Dorm Mom, Inc";
    var response = await widget.clientDataStore.createPaymentIntent(intent);

Confirm Payment Intent to Kick Off 3D Authentication #

var intentResponse = await FlutterStripePayment.confirmPaymentIntent(
          response.clientSecret, widget.order.cart.total);

      if (intentResponse.status == PaymentIntentResponseStatus.succeeded) {
        widget.order.paymentIntentId = intentResponse.paymentIntentId;
        widget.order.paymentMethodId = paymentMethodId;
        _submitOrder();
      } else if (intentResponse.status == PaymentIntentResponseStatus.failed) {
        setState(() {
          hideBusy();
        });
        globals.Utility.showAlertPopup(
            context, "Error Occurred", intentResponse.errorMessage);
      } else {
        setState(() {
          hideBusy();
        });
      }

Setup Payment Intent For Future Payments #

var intentResponse = await FlutterStripePayment.setupPaymentIntent(
        response.clientSecret, paymentMethodId);

    if (intentResponse.status == PaymentIntentResponseStatus.succeeded) {
      await _addCardToAccount(paymentMethodId);
    } else if (intentResponse.status == PaymentIntentResponseStatus.failed) {
      setState(() {
        hideBusy();
      });
      globals.Utility.showAlertPopup(
          context, "Error Occurred", intentResponse.errorMessage);
    } else {
      setState(() {
        hideBusy();
      });
    }

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  woosignal_stripe: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:woosignal_stripe/woosignal_stripe.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
69
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65
Overall:
Weighted score of the above. [more]
78
Learn more about scoring.

We analyzed this package on Jan 19, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance issues and suggestions

Repository URL doesn't exist. (-10 points)

At the time of the analysis the repository field https://github.com/woosignal/woosignal-stripe was unreachable.

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test