woocommerce_api 0.0.6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 79

woocommerce_api #

A dart package to interact with the WooCommerce API. It uses OAuth1.0a behind the scenes to generate the signature and URL string. It then makes calls and return the data back to the calling function.

Complete Usage Example #

import 'dart:async';

import 'package:flutter/material.dart';
import 'package:woocommerce_api/woocommerce_api.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Flutter Demo',
      theme: new ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: new MyHomePage(title: 'WooCommerce API Demo'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => new _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {

  List<Widget> products = [];

  Future getProducts() async {

    /// Initialize the API
    WooCommerceAPI wc_api = new WooCommerceAPI(
        "http://samarth.todaylivedeal.com",
        "ck_2b548f9652a3468f67bbc5bdb04e48edf270a000",
        "cs_fa349f1ba49b519ba9493eb2b64c88781b286b52"
    );
    
    /// Get data using the endpoint
    var p = await wc_api.getAsync("products");
    return p;
  }

  @override
  void initState() {
    super.initState();
  }

  @override
  Widget build(BuildContext context) {
    return new Scaffold(
      appBar: new AppBar(
        title: new Text(widget.title),
      ),
      body: FutureBuilder(
        future: getProducts(),
        builder: (_, s){

          if(s.data == null){
            return Container(
              child: Center(
                child: Text("Loading..."),
              ),
            );
          }

          return ListView.builder(
            itemCount: s.data.length,
            itemBuilder: (_, index){
            
            /// create a list of products
              return ListTile(
                leading: CircleAvatar(
                  child: Image.network(s.data[index]["images"][0]["src"]),
                ),
                title: Text(s.data[index]["name"]),
                subtitle: Text("Buy now for \$ " + s.data[index]["price"]),
              );

            }
          );
        },
      ),
    );
  }
}

Output #

Example code's output

[0.0.6]

  • Fixed a fatal bug in types

[0.0.5]

  • Updated to work with HTTPS websites
  • Minor bug fixes
  • Updated ReadMe

[0.0.4]

  • Fixed to work without the query_string package
  • Minor bug fixes

[0.0.3]

  • Updated SDK version upper limit for new Dart version

[0.0.2]

  • Updated docs

[0.0.1]

  • Added getAsync and postAsync functions.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  woocommerce_api: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:woocommerce_api/woocommerce_api.dart';
  
Version Uploaded Documentation Archive
0.0.8 Apr 11, 2019 Go to the documentation of woocommerce_api 0.0.8 Download woocommerce_api 0.0.8 archive
0.0.7 Mar 15, 2019 Go to the documentation of woocommerce_api 0.0.7 Download woocommerce_api 0.0.7 archive
0.0.6 Oct 1, 2018 Go to the documentation of woocommerce_api 0.0.6 Download woocommerce_api 0.0.6 archive
0.0.5 Oct 1, 2018 Go to the documentation of woocommerce_api 0.0.5 Download woocommerce_api 0.0.5 archive
0.0.4 Sep 26, 2018 Go to the documentation of woocommerce_api 0.0.4 Download woocommerce_api 0.0.4 archive
0.0.3 Sep 2, 2018 Go to the documentation of woocommerce_api 0.0.3 Download woocommerce_api 0.0.3 archive
0.0.2 Apr 18, 2018 Go to the documentation of woocommerce_api 0.0.2 Download woocommerce_api 0.0.2 archive
0.0.1 Apr 18, 2018 Go to the documentation of woocommerce_api 0.0.1 Download woocommerce_api 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
67
Overall:
Weighted score of the above. [more]
79
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/woocommerce_api.dart. (-2.96 points)

Analysis of lib/woocommerce_api.dart reported 6 hints, including:

line 9 col 8: Unused import: 'package:http/http.dart'.

line 33 col 23: Name non-constant identifiers using lowerCamelCase.

line 38 col 9: The value of the local variable 'token_secret' isn't used.

line 38 col 9: Name non-constant identifiers using lowerCamelCase.

line 53 col 21: The operator x ~/ y is more efficient than (x / y).toInt().

Fix lib/query_string.dart. (-0.50 points)

Analysis of lib/query_string.dart reported 1 hint:

line 2 col 3: Prefer using /// for doc comments.

Maintenance suggestions

The package description is too short. (-13 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and woocommerce_api.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <3.0.0
crypto ^2.0.2+1 2.0.6
flutter 0.0.0
http ^0.11.3+16 0.11.3+17 0.12.0+2
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test