woocommerce_api 0.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 80

woocommerce_api #

A dart package to interact with the WooCommerce API. It uses OAuth1.0a behind the scenes to generate the signature and URL string. It then makes calls and return the data back to the calling function.

Getting Started #

  • Import the package

import 'package:woocommerce_api/woocommerce_api.dart';

  • Initialize the SDK
WooCommerceAPI wc_api = new WooCommerceAPI(
    "http://www.mywoocommerce.com",
    "ck_...",
    "cs_..."
);
  • Use functions
List _products = new List();

wc_api.getAsync("products?page=2").then((val) {  
    List parsedMap = JSON.decode(val.body);
    setState(() {
    parsedMap.forEach((f){
        _products.add(f);
    }); 
    print(_products.length);
    });
});

[0.0.4]

  • Fixed to work without the query_string package
  • Minor bug fixes

[0.0.3]

  • Updated SDK version upper limit for new Dart version

[0.0.2]

  • Updated docs

[0.0.1]

  • Added getAsync and postAsync functions.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  woocommerce_api: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:woocommerce_api/woocommerce_api.dart';
  
Version Uploaded Documentation Archive
0.0.8 Apr 11, 2019 Go to the documentation of woocommerce_api 0.0.8 Download woocommerce_api 0.0.8 archive
0.0.7 Mar 15, 2019 Go to the documentation of woocommerce_api 0.0.7 Download woocommerce_api 0.0.7 archive
0.0.6 Oct 1, 2018 Go to the documentation of woocommerce_api 0.0.6 Download woocommerce_api 0.0.6 archive
0.0.5 Oct 1, 2018 Go to the documentation of woocommerce_api 0.0.5 Download woocommerce_api 0.0.5 archive
0.0.4 Sep 26, 2018 Go to the documentation of woocommerce_api 0.0.4 Download woocommerce_api 0.0.4 archive
0.0.3 Sep 2, 2018 Go to the documentation of woocommerce_api 0.0.3 Download woocommerce_api 0.0.3 archive
0.0.2 Apr 18, 2018 Go to the documentation of woocommerce_api 0.0.2 Download woocommerce_api 0.0.2 archive
0.0.1 Apr 18, 2018 Go to the documentation of woocommerce_api 0.0.1 Download woocommerce_api 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
75
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
67
Overall:
Weighted score of the above. [more]
80
Learn more about scoring.

We analyzed this package on May 23, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.16
  • Flutter: 1.5.4-hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/woocommerce_api.dart. (-2.48 points)

Analysis of lib/woocommerce_api.dart reported 5 hints:

line 25 col 23: Name non-constant identifiers using lowerCamelCase.

line 29 col 9: The value of the local variable 'token_secret' isn't used.

line 29 col 9: Name non-constant identifiers using lowerCamelCase.

line 39 col 21: The operator x ~/ y is more efficient than (x / y).toInt().

line 45 col 9: The value of the local variable 'path' isn't used.

Fix lib/query_string.dart. (-0.50 points)

Analysis of lib/query_string.dart reported 1 hint:

line 2 col 3: Prefer using /// for doc comments.

Maintenance suggestions

The package description is too short. (-13 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and woocommerce_api.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <3.0.0
crypto ^2.0.2+1 2.0.6
flutter 0.0.0
http ^0.11.3+16 0.11.3+17 0.12.0+2
Transitive dependencies
async 2.2.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
sky_engine 0.0.99
source_span 1.5.5
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test