woo_commerce_api_dart 0.0.3

woocommerce_api #

A dart package to interact with the WooCommerce API. It uses OAuth1.0a behind the scenes to generate the signature and URL string. It then makes calls and return the data back to the calling function.

Getting Started #

  • Import the package

import 'package:woo_commerce_api_dart/woo_commerce_api.dart';

  • Initialize the SDK
WooCommerceAPI wcApi = new WooCommerceAPI(
  • Use functions
List _products = new List();

wcApi.getAsync("products?page=2").then((val) {
    List parsedMap = val;
    setState(() {

[0.0.3] - 16/09/18

  • Auth token params added in POST requests

[0.0.2] - 30/08/18

  • Updated to support dart 2+ version

[0.0.1] - 30/08/18

  • Added getAsync and postAsync functions.


import 'package:woo_commerce_api_dart/woo_commerce_api.dart';

void main() {
  final wcApi = WooCommerceAPI(
      "http://www.bookinthecity.com", "ck_xxxxxxxxx", "cs_xxxxxxxxx");

  wcApi.getAsync('products/categories').then((response) {

  wcApi.postAsync('customers', {
    "email": 'john.doe@example.com',
    "first_name": 'John',
    "last_name": 'Doe',
    "username": 'john.doe',
    "password": 'xxxx'
  }).then((response) {

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  woo_commerce_api_dart: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:woo_commerce_api_dart/woo_commerce_api.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 21, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health issues and suggestions

Document public APIs. (-1 points)

12 out of 12 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (http).

Package is getting outdated. (-43.56 points)

The package was last published 74 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
crypto ^2.0.6 2.1.4
flutter 0.0.0
http ^0.11.3+17 0.11.3+17 0.12.0+4
Transitive dependencies
async 2.4.0
charcode 1.1.3
collection 1.14.11 1.14.12
convert 2.1.1
http_parser 3.1.3
meta 1.1.8
path 1.6.4
sky_engine 0.0.99
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies