windows_clipboard 1.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 53

A simple command-line application.

Created from templates made available by Stagehand under a BSD-style license.

1.0.0 #

  • Initial version, created by Stagehand

1.0.1 #

  • Fix setClipboardString
  • Score improvements
  • Minor changes

1.1.0 #

  • Add tryGetClipboardString

example/example.dart

import 'package:windows_clipboard/windows_clipboard.dart';

void main() {
//  var currentValue = getClipboardString();
//  print('Current clipboard: $currentValue');
  var clip = 'Hello world';
  setClipboardString(clip);
//  var newValue = getClipboardString();
//  print('New clipboard: $newValue');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  windows_clipboard: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:windows_clipboard/windows_clipboard.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
7
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
53
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-web on web

Because of the import of dart:ffi via the import chain package:windows_clipboard/windows_clipboard.dartpackage:windows_clipboard/raw_clipboard.dartpackage:windows_clipboard/src/set_clipboard_data.dartpackage:windows_clipboard/src/dlls.dartdart:ffi

Package not compatible with runtime web

Because of the import of dart:ffi via the import chain package:windows_clipboard/windows_clipboard.dartpackage:windows_clipboard/raw_clipboard.dartpackage:windows_clipboard/src/set_clipboard_data.dartpackage:windows_clipboard/src/dlls.dartdart:ffi

Health suggestions

Fix bin/main.dart. (-0.50 points)

Analysis of bin/main.dart reported 1 hint:

line 2 col 8: Unused import: 'dart:io'.

Format lib/src/empty_clipboard.dart.

Run dartfmt to format lib/src/empty_clipboard.dart.

Format lib/windows_clipboard.dart.

Run dartfmt to format lib/windows_clipboard.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
ffi ^0.1.3 0.1.3
Dev dependencies
effective_dart ^1.2.1