wifi_flutter 0.1.0+1

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

wifi_flutter #

A simple plugin that allows network scanning on android.

Getting Started #

In your pubspec add the dependency wifi_flutter: ^0.1.0+1

Due to iOS limitations, it is impossible to retrieve a list of nearby wifi networks. Unfortunately the same will hold true for android R+. However, for the time being, this simple plugin will return a list of wifi networks on android.

networks is a list of WifiNetwork each wifiNetwork object contains the SSID, RSSI (signal strength), and a boolean flag indicating if the network is secure.

Import #

import 'package:wifi_flutter/wifi_flutter.dart';

Commands #

final networks = WifiFlutter.wifiNetworks;

Retrieves the most recent wifi networks. The scan is done periodically by android so this list shouldn't be terribly out of date.

final networks = WifiFlutter.scanNetworks();

Attempts a network scan and retrieves a list of the results of that scan.

final prompted = WifiFlutter.promptPermissions();

If the required permissions are not accessible, this will prompt the user for them. It returns true if it made a prompt (the permissions weren't available) or false if it didn't make a prompt (the permissions were available and the code that requires the permissions can be run).

0.1.0+1 #

  • Improved pubspec description

0.1.0 #

  • Created simple android plugin for querying nearby wifi networks

example/README.md

wifi_flutter_example #

Demonstrates how to use the wifi_flutter plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  wifi_flutter: ^0.1.0+1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:wifi_flutter/wifi_flutter.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
32
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Oct 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test