widget_spinner 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 48

widget_spinner #

Widget Spinner animation!

Inspired by fidget spinners.

Usage / Example #

WidgetSpinner(
    // How many turns will the animation go for
    turns: 10,
    // How long will the animation last
    duration: 10,
    // Widget that spins
    child: Container(
        width: 200,
        height: 200,
        color: Colors.red,
    ),
)

Widget Spinner

[0.0.1] #

  • Initial release.

[0.0.2] #

  • ADD LICENSE

[0.0.3] #

  • ADD DESCRIPTION AND EXAMPLE

example/main.dart

import 'package:flutter/material.dart';
import 'package:widget_spinner/widget_spinner.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Widget Spinner Test',
      home: WidgetSpinnerExample(),
    );
  }
}

class WidgetSpinnerExample extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text('Widget Spinner Test'),
      ),
      body: Center(
        child: WidgetSpinner(
          child: Container(
            width: 200,
            height: 200,
            color: Colors.red,
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  widget_spinner: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:widget_spinner/widget_spinner.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Mar 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test