widget_fader 0.1.0

widget_fader #

Cross-fades widgets in both directions. Supports:

  • Infinite cross-fading in both directions
  • Swipe to fade
  • Fading via the functions next() and previous()

Example #

Installation #

Add widget_fader: ^0.1.0 in your pubspec.yaml dependencies. And import it:

import 'package:widget_fader/widget_fader.dart';

How to use #

List<Widget> _buildWidgetFaderChildren() {
    var assetPath = "assets/widgetFader";

    return List.generate(
      3, 
      (i) => Container(
        child: Image.asset(
          assetPath + i.toString() + ".jpg",
          fit: BoxFit.cover,
        ),
      )
    );
}

WidgetFader _buildWidgetFader() => WidgetFader(
    children: _buildWidgetFaderChildren(),
    fadeDuration: 750,
    pauseDuration: 750,
    cover: Column(
      children: <Widget>[
        Expanded(child: Container()),
        Container(
          height: 150,
          decoration: BoxDecoration(
            image: DecorationImage(
              image: AssetImage("assets/widgetFaderCover.jpg"),
              fit: BoxFit.cover
            )
          ),
        )
      ],
    ),
);

Future functionality #

  • Got any ideas? Make a feature request at the repo or contact me.
  • Rotation
  • Scaling

[0.0.1] - Initial release.

[0.0.2] - Make readme and pubspec.yaml more useful.

[0.0.3] - Make changelog useful.

[0.0.4] - Nothing of interest.

[0.0.5] - Implemented methods to fade to next or previous page.

[0.0.6] - Implemented swipe to fade. Updated pubspec.yaml for better example.

[0.1.0] - Changed the order of the children of the main stack to enable gesture detection on the cover.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  widget_fader: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:widget_fader/widget_fader.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/widget_fader.dart.

Run flutter format to format lib/widget_fader.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (rxdart).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and widget_fader.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
carousel_slider ^1.3.0 1.3.0
flutter 0.0.0
rxdart ^0.21.0 0.21.0 0.22.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin