widget_did_build 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 73

Widget Did Build #

When you find your self wanting to run a function once with context after a widget build has been completed, the current flutter system makes it difficult to accomplish.

This is a simple library that makes it easy to run a function that takes in a context and runs once after the widget is built. Similar to componentDidMount in React.

Usage #

This is what you state class will look like in the end

import 'package:widget_did_build/widget_did_build.dart'; // 1 - Import the widget_did_build_package

class _MyAppState extends State<MyApp> with DidBuild {  // 2-  Use DidBuild Mixin

  void didBuild(BuildContext context) { // 3 - Override and implement the didBuild method
    //  4 - Your logic goes here  

  Widget build(BuildContext context) {
    return Container();

0.0.1 #

  • TODO: Describe initial release.


widget_did_build_example #

Demonstrates how to use the widget_did_build plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  widget_did_build: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:widget_did_build/widget_did_build.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 27, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies