white_board_flutter 0.0.13

  • Readme
  • Changelog
  • Example
  • Installing
  • 38

white_board_flutter #

pub package


Usage #

  • 添加 white_board_flutterpubspec.yaml file.
  • import 'package:white_board_flutter/white_board_flutter.dart';
  • 构建白板WhiteBoardWidget,调用接口WhiteBoardFlutter


  • 升级白板


  • 添加移除直播流接口


  • 调整Android白板依赖方式


  • 修复文字bug


  • 修复白板事件监听器bug


  • 修复白板bug


  • 回滚Android依赖


  • 修复接口名称bug


  • 升级Android白板


  • 兼容flutter beta版


  • 完成白板截图功能


  • 初步完成Android插件


white_board_flutter_example #

Demonstrates how to use the white_board_flutter plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  white_board_flutter: ^0.0.13

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:white_board_flutter/white_board_flutter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Oct 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

Homepage URL isn't helpful. (-10 points)

Update the homepage field from pubspec.yaml: link to a website about the package or use the source repository URL.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8