weui 0.0.5

weui pub package

用flutter实现的weui框架, 实现了weui大部分的组件, 同时支持android 和 ios, 欢迎大家使用和交流 #

app下载 #

  • android #

  • ios 暂无下载地址, 需手动执行安装 #

文档 #

预览图 #

  

  

安装 #

weui: 0.0.4

如何运行案例 #

1. clone 代码 #

git clone https://github.com/allan-hx/flutter-weui.git

2. 安装依赖 #

flutter packages get

3. 进入flutter-weui-example目录 执行以下命令 #

flutter run

0.0.4 #

修改 #

  • WeInput添加height参数, 设置高度
  • WeInput添加maxLength参数, 限制最大输入数量
  • WeInput添加focusNode参数, 原生FocusNode
  • WeForm添加spacing参数, 设置表单内做边空白间距
  • WeForm添加boxBorder参数, 控制表单外层是否显示边框
  • WeToast.fail方法添加onClose回掉
  • WeToast.success方法添加onClose回掉

新增 #

  • 新增WeTheme类, 全局控制主题
  • 新增WeCheckbox组件
  • 新增WeRadio组件

修复 #

  • 修复WeInput组件多行输入时无法点击键盘的换行
  • 修复WeGrid组件中itemBuilder没有返回正确的index

0.0.5 #

新增 #

  • 新增WeSpin组件

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  weui: ^0.0.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:weui/weui.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
69
Health:
Code health derived from static analysis. [more]
95
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
40
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Sep 13, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.2

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/toast/index.dart. (-1 points)

Analysis of lib/toast/index.dart reported 2 hints:

line 58 col 13: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 130 col 9: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/utils.dart. (-1 points)

Analysis of lib/utils.dart reported 2 hints:

line 39 col 3: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

line 41 col 12: The class 'Future' wasn't exported from 'dart:core' until version 2.1, but this code is required to be able to run on earlier versions.

Fix lib/button/index.dart. (-0.50 points)

Analysis of lib/button/index.dart reported 1 hint:

line 19 col 7: This class (or a class which this class inherits from) is marked as '@immutable', but one or more of its instance fields are not final: WeButton.child, WeButton.sizeType, WeButton.size

Fix additional 40 files with analysis or formatting issues. (-3 points)

Additional issues in the following files:

  • lib/cell/index.dart (1 hint)
  • lib/check_list/index.dart (1 hint)
  • lib/input/index.dart (1 hint)
  • lib/notify/index.dart (1 hint)
  • lib/radio_list/index.dart (1 hint)
  • lib/tip/index.dart (1 hint)
  • lib/actionsheet/android_widget.dart (Run flutter format to format lib/actionsheet/android_widget.dart.)
  • lib/actionsheet/index.dart (Run flutter format to format lib/actionsheet/index.dart.)
  • lib/actionsheet/ios_widget.dart (Run flutter format to format lib/actionsheet/ios_widget.dart.)
  • lib/actionsheet/utils.dart (Run flutter format to format lib/actionsheet/utils.dart.)
  • lib/animation/fade_in.dart (Run flutter format to format lib/animation/fade_in.dart.)
  • lib/animation/rotating.dart (Run flutter format to format lib/animation/rotating.dart.)
  • lib/animation/scale.dart (Run flutter format to format lib/animation/scale.dart.)
  • lib/badge/index.dart (Run flutter format to format lib/badge/index.dart.)
  • lib/checkbox/index.dart (Run flutter format to format lib/checkbox/index.dart.)
  • lib/collapse/index.dart (Run flutter format to format lib/collapse/index.dart.)
  • lib/dialog/android_widget.dart (Run flutter format to format lib/dialog/android_widget.dart.)
  • lib/dialog/index.dart (Run flutter format to format lib/dialog/index.dart.)
  • lib/dialog/ios_widget.dart (Run flutter format to format lib/dialog/ios_widget.dart.)
  • lib/dialog/layout_hoc.dart (Run flutter format to format lib/dialog/layout_hoc.dart.)
  • lib/drawer/drawer.dart (Run flutter format to format lib/drawer/drawer.dart.)
  • lib/drawer/index.dart (Run flutter format to format lib/drawer/index.dart.)
  • lib/form/index.dart (Run flutter format to format lib/form/index.dart.)
  • lib/grid/index.dart (Run flutter format to format lib/grid/index.dart.)
  • lib/icon/index.dart (Run flutter format to format lib/icon/index.dart.)
  • lib/image_preview/index.dart (Run flutter format to format lib/image_preview/index.dart.)
  • lib/image_preview/preview_widget.dart (Run flutter format to format lib/image_preview/preview_widget.dart.)
  • lib/loadmore/index.dart (Run flutter format to format lib/loadmore/index.dart.)
  • lib/notice_bar/index.dart (Run flutter format to format lib/notice_bar/index.dart.)
  • lib/notify/notify.dart (Run flutter format to format lib/notify/notify.dart.)
  • lib/picker_view/index.dart (Run flutter format to format lib/picker_view/index.dart.)
  • lib/progress/index.dart (Run flutter format to format lib/progress/index.dart.)
  • lib/radio/index.dart (Run flutter format to format lib/radio/index.dart.)
  • lib/slider/index.dart (Run flutter format to format lib/slider/index.dart.)
  • lib/spin/index.dart (Run flutter format to format lib/spin/index.dart.)
  • lib/swipe/index.dart (Run flutter format to format lib/swipe/index.dart.)
  • lib/switch/index.dart (Run flutter format to format lib/switch/index.dart.)
  • lib/theme/index.dart (Run flutter format to format lib/theme/index.dart.)
  • lib/toast/info.dart (Run flutter format to format lib/toast/info.dart.)
  • lib/toast/toast.dart (Run flutter format to format lib/toast/toast.dart.)

Maintenance issues and suggestions

The description contains too many non-ASCII characters. (-20 points)

The site uses English as its primary language. The value of the description field in your package's pubspec.yaml field should primarily contain characters used in English.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and weui.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test