webservant 0.1.1

Webservant #

A simple Dart Webserver library for small REST Services

This library is a simplified interface to interact with the dart:io Webserver

See more #

To see more take a look at the examples

0.1.1 #

  • Changed Readme

0.1.0 #

  • Ready for Pre-Release

0.0.2 #

  • Formatted Code and changed description

0.0.1 #

  • Initial version

example/README.md

Example #

Set up a simple Webserver #

var webserver = Webserver();
webserver.get('/search/:query', (Response response) {
 response.write(response.urlParams);
 response.send();
});
webserver.run();

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  webservant: ^0.1.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:webservant/webservant.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
47
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Feb 12, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.5.0 <3.0.0
Dev dependencies
pedantic ^1.8.0
test ^1.6.0