webgl2_fundamentals_utils 0.1.0+2

  • Readme
  • Changelog
  • Example
  • Installing
  • 50

webgl2_fundamentals_utils #

Set of utilities for webgl2 based on Gregg Tavares webgl-utils.js for the WebGL2 Fundamentals tutorials.

Usage #

A simple usage example:

import 'dart:html';
import 'package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dart';

void main() {
  final cv = CanvasElement();
  resizeCanvasToDisplaySize(cv, multiplier: 2);
}

Features and bugs #

Please file feature requests and bugs at the issue tracker.

0.1.0+2 #

  • Delete library directive.

0.1.0+1 #

  • Change Shader arrays from const to final

0.1.0 #

  • Initial version

example/example.dart

import 'dart:html';

import 'package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dart';

void main() {
  final cv = CanvasElement();
  resizeCanvasToDisplaySize(cv, multiplier: 2);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  webgl2_fundamentals_utils: ^0.1.0+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
50
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13

Analysis suggestions

Package not compatible with runtime flutter-native on android

Because of the import of dart:web_gl via the import chain package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dartdart:web_gl

Package not compatible with runtime flutter-native on ios

Because of the import of dart:web_gl via the import chain package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dartdart:web_gl

Package not compatible with runtime flutter-native on linux

Because of the import of dart:web_gl via the import chain package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dartdart:web_gl

Package not compatible with runtime flutter-native on macos

Because of the import of dart:web_gl via the import chain package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dartdart:web_gl

Package not compatible with runtime flutter-native on windows

Because of the import of dart:web_gl via the import chain package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dartdart:web_gl

Package not compatible with runtime native-aot

Because of the import of dart:web_gl via the import chain package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dartdart:web_gl

Package not compatible with runtime native-jit

Because of the import of dart:web_gl via the import chain package:webgl2_fundamentals_utils/webgl2_fundamentals_utils.dartdart:web_gl

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.8.1 <3.0.0
Dev dependencies
effective_dart ^1.2.1
test ^1.14.4