webext 0.1.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

Overview #

This Dart package contains APIs for building browser extensions for Chrome, Edge, and Firefox.

Currently the package supports only a small set of APIs. If you want more APIs, you could use package:chrome.

Licensed under the MIT License.

Contributing #

Documentation #

Getting started #

Pub package webextdev provides a convenient command-line tool.

Install webextdev:

pub global activate webextdev

Create a project:

webextdev create hello_world

Get dependencies:

cd hello_world

pub get

Run the browser extension:

pub run webextdev run --build

0.1.3 #

  • Removed an unused dependency.

0.1.2 #

  • Dependency and documentation fixes.

0.1.1 #

  • Documentation fixes.

0.1.0 #

  • Initial release

example/webext.dart

import 'package:webext/webext.dart';

Future<void> main() async {
  await BrowserAction.instance.setBadgeText("42");
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  webext: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:webext/webext.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
31
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Mar 30, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6

Health suggestions

Fix lib/webext.dart. (-0.50 points)

Analysis of lib/webext.dart reported 1 hint:

line 123 col 20: The value of the field '_js' isn't used.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
js >=0.6.1 <1.0.0 0.6.1+1
meta >=1.1.7 <2.0.0 1.1.8
Dev dependencies
pedantic ^1.8.0
test ^1.6.5