watcher 0.8.6
watcher: ^0.8.6 copied to clipboard

outdated Dart 2 incompatible

A file watcher. It monitors (currently by polling) for changes to contents of directories and notifies you when files have been added, removed, or modified.

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add watcher

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):


dependencies:
  watcher: ^0.8.6

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:watcher/watcher.dart';
59
likes
0
pub points
99%
popularity

A file watcher. It monitors (currently by polling) for changes to contents of directories and notifies you when files have been added, removed, or modified.

Homepage

Uploaders

dgrove@google.com
sigmund@google.com
nweiz@google.com
kevmoo@google.com
rnystrom@google.com
grouma@google.com
nbosch@google.com
jakemac@google.com

License

LICENSE

Dependencies

crypto, path

More

Packages that depend on watcher