walletpackage 1.0.23

  • Readme
  • Changelog
  • Example
  • Installing
  • 46

walletpackage #

Wallet package with these functions:

ChangePassword

CreateMnemonicAndAddress

ImportMnemonicAndAddress

SignTransaction

...

1.0.23 #

  • Initial version, created by leo

example/example.dart

import 'package:walletpackage/walletpackage.dart';

void main() {
  testCreateMnemonicAndAddress();
}

Future<void> testCreateMnemonicAndAddress() async {
  WalletData walletData = await WalletProxy.createMnemonicAndAddress('123456');
  print(walletData.mnemonic);
  print(walletData.keystore);
  print(walletData.addresses);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  walletpackage: ^1.0.23

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:walletpackage/walletpackage.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
6
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Jul 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • walletpackage that is a package requiring null.

Package not compatible with runtime flutter-web on web

Because:

  • package:walletpackage/walletpackage.dart that imports:
  • package:walletpackage/src/ethereumTransaction.dart that imports:
  • package:walletpackage/src/walletProxy.dart that imports:
  • package:web3dart/web3dart.dart that imports:
  • package:isolate/isolate.dart that imports:
  • package:isolate/registry.dart that imports:
  • package:isolate/ports.dart that imports:
  • dart:isolate

Health issues and suggestions

Document public APIs. (-1 points)

66 out of 66 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/payments/p2sh.dart. (-1.99 points)

Analysis of lib/src/payments/p2sh.dart reported 4 hints:

line 5 col 8: Don't import implementation files from another package.

line 6 col 8: Don't import implementation files from another package.

line 7 col 8: Don't import implementation files from another package.

line 8 col 8: Don't import implementation files from another package.

Maintenance issues and suggestions

Support latest dependencies. (-30 points)

The version constraint in pubspec.yaml does not support the latest published versions for 3 dependencies (crypton, meta, typed_data).

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
bech32 0.1.2 0.1.2
bip32 1.0.5 1.0.5
bip39 1.0.3 1.0.3
bitcoin_flutter 2.0.1 2.0.1
bs58check 1.0.1 1.0.1
crypton 1.0.8 1.0.8 1.1.0
flutter 0.0.0
meta 1.1.8 1.1.8 1.2.1
rlp 1.0.1 1.0.1
typed_data 1.1.6 1.1.6 1.2.0
web3dart 1.2.3 1.2.3 2.0.0-dev.7
Transitive dependencies
asn1lib 0.6.5
async 2.4.2
charcode 1.1.3
collection 1.14.12 1.14.13
convert 2.1.1
crypto 2.1.5
hex 0.1.2
http 0.12.1
http_parser 3.1.4
isolate 2.0.3
json_rpc_2 2.2.1
path 1.7.0
pedantic 1.9.0 1.9.1
pointycastle 1.0.2
sky_engine 0.0.99
source_span 1.7.0
stack_trace 1.9.5
stream_channel 2.0.0
string_scanner 1.0.5
term_glyph 1.1.0
uuid 2.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test