w_popup_menu 0.2.5

  • Readme
  • Changelog
  • Installing
  • 81

w_popup_menu #

A pop-up menu that mimics the iOS WeChat page.

[0.2.5]

  • 修复位置弹出错误的问题

[0.2.4]

  • 修复了menu朝下时位置计算错误的问题。
  • 更改了弹出的逻辑,更加友好。

[0.2.3]

  • 更新了「WPopupMenu」的构造函数,现在「WPopupMenu」的构造函数是和 「Container」一样的,在内部封装了一个Container,如果想要什么属性,例如margin的话,请直接在「WPopupMenu」的属性中添加,否则控件获取不到你的margin。

Getting Started #

1. Depend on it #

Add this to your package's pubspec.yaml file:

dependencies:
  w_popup_menu: ^0.2.5

2. Install it #

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it #

Now in your Dart code, you can use:

import 'package:w_popup_menu/w_popup_menu.dart';

[0.2.5]

  • 修复位置弹出错误的问题

[0.2.4]

  • 修复了menu朝下时位置计算错误的问题。
  • 更改了弹出的逻辑,更加友好。

[0.2.3]

  • 更新了「WPopupMenu」的构造函数,现在「WPopupMenu」的构造函数是和 「Container」一样的,在内部封装了一个Container,如果想要什么属性,例如margin的话,请直接在「WPopupMenu」的属性中添加,否则控件获取不到你的margin。

[0.1.0]

  • TODO: Describe initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  w_popup_menu: ^0.2.5

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:w_popup_menu/w_popup_menu.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
73
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
71
Overall:
Weighted score of the above. [more]
81
Learn more about scoring.

We analyzed this package on Oct 16, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/examples/main.dart.

Run flutter format to format lib/examples/main.dart.

Format lib/examples/popup_route_page.dart.

Run flutter format to format lib/examples/popup_route_page.dart.

Format lib/triangle_painter.dart.

Run flutter format to format lib/triangle_painter.dart.

Format lib/w_popup_menu.dart.

Run flutter format to format lib/w_popup_menu.dart.

Maintenance suggestions

The package description is too short. (-15 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and w_popup_menu.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Update README.md. (-4 points)

2 image links are insecure (e.g. http://pic.d3collection.cn/2019-08-12-153347.png), use https URLs instead.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test