value_layout_builder 0.3.1
value_layout_builder: ^0.3.1 copied to clipboard

A LayoutBuilder with an extra value. It's useful when you want to build a widget with a value computed during layout.

Use this package as a library

Depend on it

Run this command:

With Flutter:

 $ flutter pub add value_layout_builder

This will add a line like this to your package's pubspec.yaml (and run an implicit flutter pub get):

dependencies:
  value_layout_builder: ^0.3.1

Alternatively, your editor might support or flutter pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:value_layout_builder/value_layout_builder.dart';
3
likes
130
pub points
96%
popularity

Publisher

romainrastel.com

A LayoutBuilder with an extra value. It's useful when you want to build a widget with a value computed during layout.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on value_layout_builder