validadores 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 89

Validador (PT-BR) #

Este projeto tem como objetivo principal aplicação de estudos Flutter, e colaborar com a comunidade.

Instalação #

dependencies:
  validadores: ^0.0.1

#Exemplo de utilização.


Validador()
     .add(Validar.CPF, msg: 'CPF Inválido')
     .add(Validar.OBRIGATORIO, msg: 'Campo obrigatório')
     .minLength(11)
     .maxLength(11)
     .valido(value,clearNoNumber: true);`
   

            TextFormField(
                  validator: (value) {
                    // Aqui entram as validações
                    return Validador()
                        .add(Validar.CPF, msg: 'CPF Inválido')
                        .add(Validar.OBRIGATORIO, msg: 'Campo obrigatório')
                        .minLength(11)
                        .maxLength(11)
                        .valido(value,clearNoNumber: true);

                  },
                  decoration: InputDecoration(
                    helperText: 'informe seu cpf',
                    hintText: '123.456.789-00',
                    labelText: 'CPF'
                  ),
                ),

Validadores #

  • CPF
  • CNPJ
  • OBRIGATORIO
  • EMAIL
  • IGUAL
  • Valor Mínimo
  • Valor Máximo
  • Tamanho Mínimo
  • Tamanho Máximo

0.0.1 #

Inicial

0.0.2 #

fix Health suggestions

1.0.1 #

release

1.0.2 #

fix Health suggestions

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:validadores/Validador.dart';

void main() => runApp(MalidadoresMain());

class MalidadoresMain extends StatelessWidget {


  @override
  Widget build(BuildContext context) {

    final _formKey = GlobalKey<FormState>();

    return MaterialApp(
      title: 'Validador',
      debugShowCheckedModeBanner: false,
      home: Scaffold(
        appBar: AppBar(
          title: Text('Validadores'),
        ),
        body: Form(
          key: _formKey,
          child: Container(
            padding: EdgeInsets.all(20),
            child: Column(
              children: <Widget>[
                TextFormField(
                  validator: (value) {
                    // Aqui entram as validações
                    return Validador()
                        .add(Validar.CPF, msg: 'CPF Inválido')
                        .add(Validar.OBRIGATORIO, msg: 'Campo obrigatório')
                        .minLength(11)
                        .maxLength(11)
                        .valido(value,clearNoNumber: true);

                  },
                  decoration: InputDecoration(
                    helperText: 'informe seu cpf',
                    hintText: '123.456.789-00',
                    labelText: 'CPF'
                  ),
                ),
        RaisedButton(
          onPressed: () {
            if (_formKey.currentState.validate()) {
              print('Valido');
            }
          },
          child: Text('Enviar'),
        )
              ],
            )
          ),
        ),
      )
      ,
    );
  }

}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  validadores: ^1.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:validadores/validadores.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
79
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
89
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:validadores/validadores.dart] that declares support for platforms: android, ios, macos

Package does not support Flutter platform web

Because of import path [package:validadores/validadores.dart] that declares support for platforms: android, ios, macos

Package does not support Flutter platform windows

Because of import path [package:validadores/validadores.dart] that declares support for platforms: android, ios, macos

Package not compatible with SDK dart

because of import path [validadores] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test