url 2.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 84

Url class that implements Uri. Use this class to specify an URL Url is required in your API, not just an Uri.

Checks whether an URL is valid using the validators package.

Usage #

import 'package:url/url.dart';

main() {
  final url = Url.parse('https://pattle.im');
}

2.0.0 #

  • Relicense to MPL-2.0

1.0.1 #

  • Run dartfmt
  • Update package description
  • Update README

1.0.0 #

  • Initial version

example/url_example.dart

import 'package:url/url.dart';

main() {
  final url = Url.parse('https://pattle.im');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  url: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:url/url.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
69
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Oct 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:url/url.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.0 <3.0.0
validators ^2.0.0 2.0.0+1
Dev dependencies
pedantic ^1.0.0
test ^1.0.0