urban_api 1.0.2

  • Readme
  • Changelog
  • Example
  • Installing
  • 45

urban-api Pub documentation #

Wrapper for UrbanDictionary api to easy access to its resources.


Library contains only one method getDefinitions(String word) to get definitions for specified word

// Get definitions for word
var res = await getDefinitions("shit");

print("Authors of definitions");
for(var i in res)
  print("== ${i.author}");

1.0.0 #

  • Initial version, created by Stagehand


import 'package:urban_api/urban_api.dart';

main() async {
  // Get definitions for word
  var res = await getDefinitions("shit");

  print("Authors of definitions");
  for (var i in res) print("== ${i.author}");

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  urban_api: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:urban_api/urban_api.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.2
  • pana: 0.13.8-dev

Health suggestions

Fix lib/src/urban_api_base.dart. (-1 points)

Analysis of lib/src/urban_api_base.dart reported 2 hints:

line 13 col 26: Unnecessary new keyword.

line 16 col 5: DO use curly braces for all flow control structures.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field https://github.com/l7ssha/urban-api was unreachable.

Package is getting outdated. (-69.59 points)

The package was last published 88 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
http ^0.12.0 0.12.1
Transitive dependencies
charcode 1.1.3
collection 1.14.12
http_parser 3.1.4
meta 1.1.8
path 1.7.0
pedantic 1.9.0
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6