upnp 2.0.0+1

UPnP Client for Dart #

Features #

  • Discovery
  • Device Information
  • Services
  • Actions
  • Host Support
  • DIAL API
  • Router API

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  upnp: ^2.0.0+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:upnp/upnp.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
65
Health:
Code health derived from static analysis. [more]
57
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
37
Overall:
Weighted score of the above. [more]
57
Learn more about scoring.

We analyzed this package on Dec 10, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21

Health issues and suggestions

Document public APIs. (-1 points)

280 out of 280 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Fix lib/src/discovery.dart. (-16.93 points)

Analysis of lib/src/discovery.dart reported 37 hints, including:

line 3 col 39: Unnecessary new keyword.

line 4 col 39: Unnecessary new keyword.

line 9 col 5: Unnecessary new keyword.

line 13 col 26: Use = to separate a named parameter from its default value.

line 13 col 43: Use = to separate a named parameter from its default value.

Fix lib/src/sub_manager.dart. (-6.78 points)

Analysis of lib/src/sub_manager.dart reported 14 hints, including:

line 43 col 7: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

line 54 col 25: Unnecessary new keyword.

line 68 col 25: Unnecessary new keyword.

line 122 col 19: Unnecessary new keyword.

line 138 col 5: Future results in async function bodies must be awaited or marked unawaited using package:pedantic.

Fix lib/src/server/utils.dart. (-6.31 points)

Analysis of lib/src/server/utils.dart reported 13 hints, including:

line 32 col 44: Use = to separate a named parameter from its default value.

line 33 col 14: Unnecessary new keyword.

line 34 col 18: Unnecessary new keyword.

line 36 col 15: Unnecessary new keyword.

line 36 col 52: Unnecessary new keyword.

Fix additional 14 files with analysis or formatting issues. (-22.26 points)

Additional issues in the following files:

  • lib/src/router/router.dart (8 hints)
  • lib/src/server/discovery.dart (7 hints)
  • lib/src/server/server.dart (7 hints)
  • lib/src/service.dart (6 hints)
  • lib/src/dial/screen.dart (5 hints)
  • lib/src/device.dart (3 hints)
  • lib/src/action.dart (2 hints)
  • lib/src/server/action.dart (2 hints)
  • lib/server.dart (1 hint)
  • lib/src/helpers.dart (1 hint)
  • lib/src/server/device.dart (1 hint)
  • lib/src/server/service.dart (1 hint)
  • lib/src/utils.dart (1 hint)
  • lib/src/media/sources.dart (Run dartfmt to format lib/src/media/sources.dart.)

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Package is getting outdated. (-23.29 points)

The package was last published 64 weeks ago.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example.

None of the files in the package's example/ directory matches known example patterns.

Common filename patterns include main.dart, example.dart, and upnp.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
crypto ^2.0.6 2.1.4
xml ^3.2.0 3.6.1
Transitive dependencies
charcode 1.1.2
collection 1.14.12
convert 2.1.1
meta 1.1.8
petitparser 2.4.0
typed_data 1.1.6