unofficial_mazzuma_plugin 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 37

unofficial_mazzuma_plugin #

This is an unofficial implementation of Mazzuma's payment Api in flutter

Getting Started #

Installation #

Add this to your pubspec.yaml (or create it):

  unofficial_mazzuma_plugin: x.x.x  #latest version

Then run the flutter tooling:

flutter packages get

Or upgrade the packages with:

flutter packages upgrade

import library

import 'package:unofficial_mazzuma_plugin/unofficial_mazzuma_plugin.dart';

Example #

UnofficialMazzumaPlugin mazzumaPlugin = new UnofficialMazzumaPlugin();

 void makePayment(String userNetwork, String userNumber, double paymentAmount) {
    String paymentOption;
    String myNumber = "YOUR-MOBILE-NUMBER-HERE"; 
    String myApiKey = "YOUR-API-KEY-HERE";
/** This denotes the direction of cash flow. For example, rmta can be understood as an acronym of the phrase
‘receive mtn to airtel’, which means you would be receiving money to your Airtel account (the recipient number) 
from an MTN number(the sender). This format would hold for all transaction requests sent to the API.
 Do not forget to append the r at beginning. **/
    if (userNetwork == "AIRTEL") {
      paymentOption = "ratm"; 
    } else if (userNetwork == "MTN") {
      paymentOption = "rmtm";
    } else if (userNetwork == "TIGO") {
      paymentOption = "rttm";
    } else {
      paymentOption = "unknown";
    print("network is: $userNetwork");
    print("payemnt option is: $paymentOption");
    print("payment amount is: $paymentAmount");
    print("my number is: $myNumber");
    print("user Number is: $userNumber");
    print("myApiKey is: $myApiKey");

    var response = mazzumaPlugin.processPayment(paymentAmount, userNetwork,
        myNumber, userNumber, paymentOption, myApiKey);

0.0.1 #

  • Initial version, created by Sunu Bright Etornam


import 'package:flutter/material.dart';
import 'package:unofficial_mazzuma_plugin_example/checkout_page.dart';
import 'package:unofficial_mazzuma_plugin/unofficial_mazzuma_plugin.dart';

main() {
    home: CheckOutPage(),

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  unofficial_mazzuma_plugin: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:unofficial_mazzuma_plugin/unofficial_mazzuma_plugin.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:unofficial_mazzuma_plugin/unofficial_mazzuma_plugin.dart]

Package does not support Flutter platform macos

Because of import path [package:unofficial_mazzuma_plugin/unofficial_mazzuma_plugin.dart]

Package does not support Flutter platform web

Because of import path [package:unofficial_mazzuma_plugin/unofficial_mazzuma_plugin.dart]

Package does not support Flutter platform windows

Because of import path [package:unofficial_mazzuma_plugin/unofficial_mazzuma_plugin.dart]

Package not compatible with SDK dart

because of import path [unofficial_mazzuma_plugin]

Health issues and suggestions

Document public APIs. (-1 points)

8 out of 8 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/unofficial_mazzuma_plugin.dart.

Run flutter format to format lib/unofficial_mazzuma_plugin.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (dio).

Package is getting outdated. (-41.92 points)

The package was last published 74 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
dio ^1.0.14 1.0.17 3.0.9
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
cookie_jar 0.0.8 1.0.1
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8