[unification] is a concrete implementation of logical first-order unification and library to apply a first-order unification procedure [unify] given by the library on two terms of [Termtype] given by the library.
A solution of a unification problem is a substitution, that is, a mapping assigning a symbolic value to each variable of the problem's expressions. The unification algorithm reports unsolvability for a given problem or computes a complete, and minimal singleton substitution set containing the so-called most general unifier, that is, a set covering all its solutions, and containing no redundant members.
import "package:tailcalls/tailcalls.dart"; import "package:unification/unification.dart"; var test = unify( new List() ..add( new Tupl( new Term("b0", [new Term("b1", ),new Term("b2", )]), new Term("b0", [new Term("b1", ),new Term("b2", )]), ), ), ).result(); var mgu = test; print(mgu.toString());
Read more about unification in logic on Wikipedia.
Add this to your package's pubspec.yaml file:
dependencies: unification: ^0.0.1+1
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.4||May 9, 2019|
|0.1.3||Oct 18, 2018|
|0.1.2||Sep 29, 2018|
|0.1.1||Sep 28, 2018|
|0.1.0||Sep 28, 2018|
|0.0.1+2||Sep 28, 2018|
|0.0.1+1||Dec 16, 2017|
|0.0.1||Dec 16, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.8.0 <=2.0.0-dev.8.0|