unification 0.0.1

  • README.md
  • Changelog.md
  • Installing
  • Versions
  • 0

uni #

Read more about unification in logic on Wikipedia.

Read more about trampoling in computing on Wikipedia.

Changelog #

0.0.1 #

  • Initial release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  unification: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:unification/unification.dart';
  
Version Uploaded Documentation Archive
0.1.4 May 9, 2019 Go to the documentation of unification 0.1.4 Download unification 0.1.4 archive
0.1.3 Oct 18, 2018 Go to the documentation of unification 0.1.3 Download unification 0.1.3 archive
0.1.2 Sep 29, 2018 Go to the documentation of unification 0.1.2 Download unification 0.1.2 archive
0.1.1 Sep 28, 2018 Go to the documentation of unification 0.1.1 Download unification 0.1.1 archive
0.1.0 Sep 28, 2018 Go to the documentation of unification 0.1.0 Download unification 0.1.0 archive
0.0.1+2 Sep 28, 2018 Go to the documentation of unification 0.0.1+2 Download unification 0.0.1+2 archive
0.0.1+1 Dec 16, 2017 Go to the documentation of unification 0.0.1+1 Download unification 0.0.1+1 archive
0.0.1 Dec 16, 2017 Go to the documentation of unification 0.0.1 Download unification 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <=2.0.0-dev.8.0