typedparser 0.1.2

  • README.md
  • Installing
  • Versions
  • 0

typedparser #

This library is a wrapper around the petitparser library. It adds type annotations of the produced outputs as well as some additional functionality.

Features and bugs #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.1.2 #

  • Dart 2 strong mode fixes

0.1.1 #

  • add class SettableParser and method undefined()

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  typedparser: ^0.1.2

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:typedparser/typedparser.dart';
Version Uploaded Documentation Archive
0.1.2 Apr 15, 2018 Go to the documentation of typedparser 0.1.2 Download typedparser 0.1.2 archive
0.1.1 Jan 15, 2018 Go to the documentation of typedparser 0.1.1 Download typedparser 0.1.1 archive
0.1.0 Dec 12, 2017 Go to the documentation of typedparser 0.1.0 Download typedparser 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0