typedef_for_fn_generator 1.0.2 icon indicating copy to clipboard operation
typedef_for_fn_generator: ^1.0.2 copied to clipboard

An annotation processor for @TypedefForFn annotations

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add typedef_for_fn_generator

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  typedef_for_fn_generator: ^1.0.2

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:typedef_for_fn_generator/builder.dart';
1
likes
60
pub points
0%
popularity

Publisher

unverified uploader

An annotation processor for @TypedefForFn annotations

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

analyzer, build, dartz, quiver, source_gen, typedef_for_fn

More

Packages that depend on typedef_for_fn_generator