twitter 1.0.0

twitter.dart #

Build Status pub package

Twitter Library for Dart.

Example #


import 'package:twitter/twitter.dart';

main () async {
  Twitter twitter= new Twitter('YOUR CONSUMER KEY', 'YOUR CONSUMER SERCRET',
  var response = await twitter.request("GET", "statuses/user_timeline.json");


  • Write more detailed Example
  • Support Twitter Model



oauth.dart #

In this library, use oauth.dart in My repository. I fix it by develop original oauth 1 library.

1.0.0 #

  • remove straming API support
  • support dart 2.0

0.5.1 #

  • Fix error on mulitple request (#5)

0.5.0 #

  • Fix error on strong mode
  • Add Example

0.4.1 #

  • Update OAuth.dart

0.4.0 #

  • Support Twitter Streaming API

0.3.1 #

  • Fix sdk version

0.3.0 #

  • Update dependencies
    • OAuth.dart - using function for generate randombytes
  • Fix README

0.2.0 #

  • Remove library tag
  • Add Twitter.fromMap constrcutor
  • Fix README

0.1.1 #

  • Fix problem that a delay occurs
  • Using Completer for Error Processing

0.1.0 #

Initial Version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  twitter: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:twitter/twitter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5

Health suggestions

Fix lib/twitter.dart. (-4.41 points)

Analysis of lib/twitter.dart reported 9 hints, including:

line 19 col 41: Unnecessary new keyword.

line 26 col 32: Unnecessary new keyword.

line 31 col 28: Unnecessary new keyword.

line 32 col 12: Unnecessary new keyword.

line 46 col 32: Unnecessary new keyword.

Fix lib/src/client.dart. (-1 points)

Analysis of lib/src/client.dart reported 2 hints:

line 18 col 19: Unnecessary new keyword.

line 30 col 15: Unnecessary new keyword.

Maintenance issues and suggestions

Prefer published dependencies. (-100 points)

The source code in a git repository is mutable and could disappear.

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: oauth.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (http).

Fix analysis_options.yaml.

The analyzer can't parse analysis_options.yaml.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-12.33 points)

The package was last published 58 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and twitter.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
http >=0.11.2 <0.12.0 0.11.3+17 0.12.0+4
oauth 0.4.0
Transitive dependencies
async 2.4.0
charcode 1.1.3
collection 1.14.12
convert 2.1.1
crypto 2.1.4
http_parser 3.1.3
meta 1.1.8
path 1.6.4
pointycastle 1.0.2
source_span 1.6.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
Dev dependencies
test ^1.5.1