tts 1.0.2

tts #

A text to speech plugin for flutter. Initial implementation, more to come. :)

Usage #

To use this plugin, add tts as a dependency in your pubspec.yaml file.

Example #

import 'package:flutter/material.dart';
import 'package:url_launcher/url_launcher.dart';

void main() {
  runApp(new Scaffold(
    body: new Center(
      child: new RaisedButton(
        onPressed: speak,
        child: new Text('Say Hello'),
      ),
    ),
  ));
}

speak() async {
  Tts.speak('Hello World');
}

Languages #

You can get a list of available languages (voices) supported by the OS by calling:

final languages = await Tts.getAvailableLanguages();

Checking to see if a languge can be used:

var isGoodLanguage = await Tts.isLanguageAvailable(lang);

Setting a deisred language:

var setLanguage = await Tts.setLanguage(lang);

[1.0.2] - 11/6/2018.

  • Dart 2.0.0 upgrade

[1.0.1] - 2/5/2018.

  • Minor bug fix.

[1.0.0] - 2/5/2018.

  • Adding ability to change languages.

[0.0.2] - 2/4/2018.

  • Android bug fix.

[0.0.1] - 2/4/2018.

  • initial release with basic speech functionality.

example/README.md

tts_example #

Demonstrates how to use the tts plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tts: ^1.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tts/tts.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
83
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
42
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <=3.0.0