An API wrapper for travis-ci
Full interaction with the travis-ci API v3 is planned
You can find all the info on https://pub.dartlang.org/packages/travis_dart
Create a new instance of the
Travis class, it provides a bunch of methods that you can link to the travis-ci API. Real documentation will be provided soon
Use this package as a library
1. Depend on it
Add this to your package's pubspec.yaml file:
dependencies: travis_dart: ^0.1.1
2. Install it
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
3. Import it
Now in your Dart code, you can use:
import 'package:travis_dart/models/get/branch.dart'; import 'package:travis_dart/models/get/build.dart'; import 'package:travis_dart/models/get/commit.dart'; import 'package:travis_dart/models/get/error.dart'; import 'package:travis_dart/models/get/job.dart'; import 'package:travis_dart/models/get/organization.dart'; import 'package:travis_dart/models/get/owner.dart'; import 'package:travis_dart/models/get/repository.dart'; import 'package:travis_dart/models/get/stage.dart'; import 'package:travis_dart/models/get/user.dart'; import 'package:travis_dart/models/standard_model.dart'; import 'package:travis_dart/result.dart'; import 'package:travis_dart/travis.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Apr 4, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
- Dart: 2.7.1
- pana: 0.13.6
Analysis issues and suggestions
Fix dependencies in
pub upgrade failed with the following output:
ERR: The current Dart SDK version is 2.7.1. Because travis_dart requires SDK version >2.0.0-dev <2.1.0, version solving failed.
Maintenance issues and suggestions
Support future stable Dart 2 SDKs in
pubspec.yaml. (-20 points)
The SDK constraint in
pubspec.yaml doesn't allow future stable Dart 2.x SDK releases.
No valid SDK. (-20 points)
The analysis could not detect a valid SDK that can use this package.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
Provide a file named
CHANGELOG.md. (-20 points)
Changelog entries help developers follow the progress of your package. See the example generated by
Homepage URL doesn't exist. (-20 points)
At the time of the analysis the
https://github.com/continuous-updates/travis-dart was unreachable.
Package is getting outdated. (-92.05 points)
The package was last published 100 weeks ago.
The package description is too short. (-20 points)
Add more detail to the
description field of
pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.
Maintain an example. (-10 points)
Create a short demo in the
example/ directory to show how to use this package.
Common filename patterns include
travis_dart.dart. Packages with multiple examples should provide
For more information see the pub package layout conventions.
|Dart SDK||>2.0.0-dev <2.1.0|