transformer_utils 0.2.2

Dart Transformer Utilities #

Pub Build Status documentation

Utilities relating to code generation, Dart analyzer, logging, etc. for use in Pub transformers.

Development #

This project leverages the dart_dev package for most of its tooling needs, including static analysis, code formatting, running tests, collecting coverage, and serving examples. Check out the dart_dev readme for more information.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  transformer_utils: ^0.2.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:transformer_utils/transformer_utils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
96
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
69
Learn more about scoring.

We analyzed this package on Jul 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19

Platforms

Detected platforms: other

Primary library: package:transformer_utils/transformer_utils.dart with components: io, build, mirrors.

Health suggestions

Fix lib/src/transformed_source_file.dart. (-1.49 points)

Analysis of lib/src/transformed_source_file.dart reported 3 hints:

line 19 col 1: 'package:analyzer/analyzer.dart' is deprecated and shouldn't be used.

line 54 col 54: Use = to separate a named parameter from its default value.

line 161 col 33: Use = to separate a named parameter from its default value.

Fix lib/src/barback_utils.dart. (-1 points)

Analysis of lib/src/barback_utils.dart reported 2 hints:

line 17 col 1: 'package:analyzer/analyzer.dart' is deprecated and shouldn't be used.

line 37 col 33: Use = to separate a named parameter from its default value.

Fix lib/src/text_util.dart. (-1 points)

Analysis of lib/src/text_util.dart reported 2 hints:

line 23 col 16: Use = to separate a named parameter from its default value.

line 23 col 43: Use = to separate a named parameter from its default value.

Fix lib/src/analyzer_helpers.dart. (-0.50 points)

Analysis of lib/src/analyzer_helpers.dart reported 1 hint:

line 19 col 1: 'package:analyzer/analyzer.dart' is deprecated and shouldn't be used.

Fix lib/src/node_with_meta.dart. (-0.50 points)

Analysis of lib/src/node_with_meta.dart reported 1 hint:

line 17 col 1: 'package:analyzer/analyzer.dart' is deprecated and shouldn't be used.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (analyzer).

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and transformer_utils.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
analyzer >=0.35.0 <0.37.0 0.36.4 0.37.0
build ^1.0.0 1.1.5
dart2_constant ^1.0.1 1.0.2+dart2
path ^1.3.0 1.6.2
source_span ^1.2.0 1.5.5
Transitive dependencies
args 1.5.2
async 2.3.0
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.16.1
front_end 0.1.19 0.1.20
glob 1.1.7
html 0.14.0+2
kernel 0.3.19 0.3.20
logging 0.11.3+2
meta 1.1.7
package_config 1.0.5
pedantic 1.8.0+1
pub_semver 1.4.2
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+12
yaml 2.1.16
Dev dependencies
coverage >=0.10.0 <0.13.0
dart_dev ^2.0.0
dart_style ^1.0.9
dependency_validator ^1.1.0
test ^1.5.3

Admin