transformer_test 0.2.1+2

transformer_test #

A library which provides some tools for testing Transformers.

Features #

This library provides a top level function testPhases which given a nested list of transformers to run and a list of inputs, will verify a list of expected outputs.

For example, given a transformer which copies all files to corresponding *.copy files, you could write the following test:

testPhases(
  [[new CopyTransformer()]],
  {
    'a|lib/a.dart': 'hello!'
  }, {
    'a|lib/a.dart': 'hello!'
    'a|lib/a.dart.copy': 'hello!'
  });

Issues #

Please file feature requests and bugs at the issue tracker.

Changelog #

0.2.1+2 #

  • Fix strong mode errors.
  • Add missing dependency on package:stack_trace.

0.2.1+1 #

  • Bump maximum version allowed for code_transformers. The breaking change in version 0.5.0 has no impact here.

0.2.1 #

  • Widened type of phases parameter of testPhases function, which allows to use it to test aggregate transformers and transformer groups.

0.2.0 #

  • Changed all optional arguments to testPhases to named arguments.
  • Added skip and tags named arguments to testPhases, which will be forwarded on to the call to test.
  • messages optional argument to testPhases now accepts either Matchers or Strings.
  • Added expectBarbackErrors optional argument to testPhases.

0.1.0 #

  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  transformer_test: ^0.2.1+2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:transformer_test/utils.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
2
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
1
Learn more about scoring.

This package is not analyzed, because it is discontinued.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0

Admin