torch_compat 1.0.1

Torch compat #


A plugin to enable or disable the torch of a device that works both on Android (including Android 4.x) and ioS.

Getting started #

1) Dependency setup #

First import the library to your project in your pubspec.yaml:

torch_compat: ^1.0.0

2) Import the library in your Dart code #

import 'package:torch_compat/torch_compat.dart';

3) Turn on or off the flash #


[1.0.1] - 18rd November 2019

  • The dispose() method is now available in Dart/Flutter
  • According to your scenario, it is mandatory to call it (Camera 1 requirement)

[1.0.0] - 3rd November 2019

  • Initial Release.


torch_compat_example #

Demonstrates how to use the torch_compat plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  torch_compat: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:torch_compat/torch_compat.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.5
  • Flutter: 1.12.13+hotfix.7

Health issues and suggestions

Document public APIs. (-1 points)

7 out of 7 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies