tonal 2.2.2+1 copy "tonal: ^2.2.2+1" to clipboard
tonal: ^2.2.2+1 copied to clipboard

Dart port of Tonaljs

Use this package as a library

Depend on it

Run this command:

With Dart:

 $ dart pub add tonal

This will add a line like this to your package's pubspec.yaml (and run an implicit dart pub get):

dependencies:
  tonal: ^2.2.2+1

Alternatively, your editor might support dart pub get. Check the docs for your editor to learn more.

Import it

Now in your Dart code, you can use:

import 'package:tonal/array/array.dart';
import 'package:tonal/array/test/array.test.dart';
import 'package:tonal/chord/chord.dart';
import 'package:tonal/chord/test/chord.spec.dart';
import 'package:tonal/dictionary/data/chords.dart';
import 'package:tonal/dictionary/data/scales.dart';
import 'package:tonal/dictionary/dictionary.dart';
import 'package:tonal/dictionary/test/dictionary.spec.dart';
import 'package:tonal/distance/distance.dart';
import 'package:tonal/distance/test/distance.spec.dart';
import 'package:tonal/interval/interval.dart';
import 'package:tonal/interval/test/interval.spec.dart';
import 'package:tonal/note/note.dart';
import 'package:tonal/note/test/note.spec.dart';
import 'package:tonal/pcset/pcset.dart';
import 'package:tonal/pcset/test/pcset.spec.dart';
import 'package:tonal/scale/scale.dart';
import 'package:tonal/scale/test/scale.spec.dart';
1
likes
15
pub points
8%
popularity

Publisher

unverified uploader

Dart port of Tonaljs

License

MIT (license)

Dependencies

node_shims, test

More

Packages that depend on tonal