title_bar 0.2.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 48

title_bar #

pub package License: MIT Documentation

A Flutter plugin for go-flutter, available for MacOS. It will allow you to customize your title bar by changing the color, name, hiding it, etc.

Note: This plugin is still under development, and some APIs might not be available yet. Feedback welcome and Pull Requests are most welcome!

Usage #

Import as:

import "github.com/zephylac/title_bar"

Then add the following option to your go-flutter application options:

flutter.AddPlugin(&title_bar.TitleBarPlugin{}),

More info #

If you want to check the current development status go check here

Issues #

Please report issues at the title_bar issue tracker.

# Change Log

## [v0.2.0](https://github.com/zephylac/title_bar/tree/v0.2.0) (2019-08-01)

* Updated example readme & package name

## [v0.1.0](https://github.com/zephylac/title_bar/tree/v0.1.0) (2019-07-31)
**Implemented enhancements:**

* Added example
* Added Flutter service
* Added GoDoc

example/README.md

titlebarapp #

Demonstrates how to use the title_bar plugin.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  title_bar: ^0.2.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:title_bar/title_bar.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
91
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Oct 18, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.5.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.4

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/title_bar.dart.

Run flutter format to format lib/title_bar.dart.

Maintenance suggestions

The package description is too short. (-9 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test