tiny_widgets 0.0.2

Tiny Widgets #

pub package Build Status Coverage Status

We at TinyProgrammers were copying pasting the same code in multiple projects again and again and again over the time this makes it complex to update every project we maintain to latest version of widgets.

So we created TinyWidgets. this Lib/Package contains all of our most common used Widgets with flexible parameters that you will love to work with.

Okay we shouldn't talk much and let our work impress you!

Features and Screenshots. #

Widget NameScreenshotSourcecodeExample
TinyContainerClickClick

Getting Started #

1- Add this package to your pubspec.yaml.

dependencies:
  tiny_widgets:
    git: https://github.com/TinyProgrammers/tiny_widgets.git

or

dependencies:
  tiny_widgets: any # or latest verison.

2- import the library into your widget.

import 'package:tiny_widgets/tiny_widgets.dart';

3- use any of our widgets.

Issues and feedback #

Please file issues to send feedback or report a bug. Thank you!

Changelog #

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

[Unreleased]

  • none

[0.0.2] - 19-Jun-2019

Added #

  • Added Tiny Rating Bar.

[0.0.1] - 19-Jun-2019

Added #

  • Added Tiny Container Widget.

example/README.md

Tiny Widgets Example #

Tiny Widgets Example, this project discussing the features of Tiny Widgets Lib/Packages.

Getting Started #

Navigate to main.dart to see that start point of the app.

but those are useful links too (to navigate faster if you're on pub ^^)

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tiny_widgets: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tiny_widgets/tiny_widgets.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
27
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
65
Overall:
Weighted score of the above. [more]
56
Learn more about scoring.

We analyzed this package on Jul 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.4.0
  • pana: 0.12.19
  • Flutter: 1.7.8+hotfix.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Homepage URL is insecure. (-5 points)

Update the homepage field and use a secure (https) URL.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test

Admin