timelineview 0.0.2

  • Readme
  • Changelog
  • Installing
  • 51

TimelineView #

How to use #

TimelineView(
    activeIndex: activeIndex, // active index default (0)
    showLabels: false, // weather to show lables at bottom or not default (true)
    circleRadius: 15.0, // radius of the circle ignored if selected and unSelectedWidgets are provided
    lineHeight: 2.0, // Height of line will be ignored if lineWidget is provided
    lineWidget: _lineWidget, // Widget will be placed in the line
    selectedTextStyle: , // selected item label style
    selectedWidget: , // selected widget
    unSelectedTextStyle: , // unselected item label style
    unSelectedWidget: , // unselected widget
    onChanged: (index) {
        setState(() {
            activeIndex = index;
        });
    }, // onSelection changed trigger
    labelWidgets: <Widget>[
        Text("One"),
        Text("TwoThree"),
        Text("Four"),
    ], // list of items
),

[0.0.2]

  • Minor alignment fixes

[0.0.1]

  • Initial Release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  timelineview: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:timelineview/timelineview.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
18
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
59
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Dec 9, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (animator).

The package description is too short. (-11 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and timelineview.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.2.2 <3.0.0
animator ^0.1.4 0.1.4 1.0.0+3
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
states_rebuilder 1.8.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test