timeline_list 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 88

Flutter Timeline Widget #

pub package Build Status codecov

Displays a scrollable timeline with custom child widgets and custom icons.

Flutter Timeline List Screenshot

Installation #

In your pubspec.yaml file within your Flutter Project:

dependencies:
  timeline_list: ^0.0.2

Features #

  • 3 different timeline alignments. Left, Center, Right.
  • On demand child building with Timeline.builder.
  • Custom icon and icon size support (icon sizes supported only on centered timeline).

Usage #

import 'package:timeline_list/timeline.dart';
import 'package:timeline_list/timeline_model.dart';

List<TimelineModel> items = [
      TimelineModel(Placeholder(),
          position: TimelineItemPosition.random,
          iconBackground: Colors.redAccent,
          icon: Icon(Icons.blur_circular)),
      TimelineModel(Placeholder(),
          position: TimelineItemPosition.random,
          iconBackground: Colors.redAccent,
          icon: Icon(Icons.blur_circular)),
    ];
    return Timeline(children: items, position: TimelinePosition.Center);

Example #

A sample timeline app can be found in the example/ folder.

<a href="https://ehlibyte.com"><img align="right" width="100" height="100" src="http://ehlibyte.com/images/ehlibyte-logo.svg?raw=true" /></a>

[0.0.1] - Initial release

[0.0.2] - Changing README

- Fix: Dart pub's markdown rendering issue

example/README.md

example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  timeline_list: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:timeline_list/timeline.dart';
import 'package:timeline_list/timeline_model.dart';
  
Version Uploaded Documentation Archive
0.0.4 Mar 25, 2019 Go to the documentation of timeline_list 0.0.4 Download timeline_list 0.0.4 archive
0.0.3 Jan 20, 2019 Go to the documentation of timeline_list 0.0.3 Download timeline_list 0.0.3 archive
0.0.2 Jan 16, 2019 Go to the documentation of timeline_list 0.0.2 Download timeline_list 0.0.2 archive
0.0.1 Jan 16, 2019 Go to the documentation of timeline_list 0.0.1 Download timeline_list 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
89
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
69
Overall:
Weighted score of the above. [more]
88
Learn more about scoring.

We analyzed this package on May 8, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.0
  • pana: 0.12.15
  • Flutter: 1.5.8

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The package description is too short. (-19 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Update README.md. (-2 points)

1 image link is insecure (e.g. http://ehlibyte.com/images/ehlibyte-logo.svg?raw=true), use https URLs instead.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test