time_slot_picker 0.0.1

  • Readme
  • Changelog
  • Example
  • Installing
  • 74

time_slot_picker #

A library for picking time slot from horizontal strip.

Getting Started #

1.0 Add this to your package's pubspec.yaml file:

dependencies:
  time_slot_picker: ^0.0.1

2.1 Install it with pub:

$ pub get

OR

2.2 Install it with Flutter:

$ flutter packages get

3.0 Import it in your dart code:

import 'package:time_slot_picker/time_slot_picker.dart';

4.0 Add Widget

new Container(
    child: new Column(
        mainAxisAlignment: MainAxisAlignment.start,
        children: <Widget>[
            new Container(
                color: Colors.teal,
                child: new TimeSlotPicker(
                    date: new DateTime.now().subtract(Duration(days: 5)), // (Optional)
                    slotBorder: RoundedRectangleBorder(borderRadius: BorderRadius.circular(30.0)), // (Optional)
                    textStyle: TextStyle(color: Colors.white), // (Optional)
                    onTap: (DateTime startTime, DateTime endTime){ // (Required)
                        print(startTime.toString() +" >> "+endTime.toString());
                    },
                ),
            ),
        ],
    ),
),

date - (Optional) Add date if you need to get time with preset date. slotBorder - (Optional) Add slotBorder if you need to change border of time slot button. Default 'circular'. textStyle - (Optional) Add textStyle to change text appearance. onTap - (Required) You must add this event to get StartTime and EndTime of slot.

Output #

0.0.1 #

  • Initial Open Source release.

example/main.dart

import 'package:flutter/material.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  @override
  Widget build(BuildContext context) {
    return Container(
      child: new Center(
        child: new Text("meme"),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  time_slot_picker: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:time_slot_picker/time_slot_picker.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
69
Health:
Code health derived from static analysis. [more]
97
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
51
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Dec 11, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.1
  • pana: 0.13.1+4
  • Flutter: 1.12.13+hotfix.2

Health suggestions

Fix lib/slot.dart. (-2.96 points)

Analysis of lib/slot.dart reported 6 hints, including:

line 6 col 14: Avoid wrapping fields in getters and setters just to be "safe".

line 8 col 7: Avoid wrapping fields in getters and setters just to be "safe".

line 12 col 16: Avoid wrapping fields in getters and setters just to be "safe".

line 14 col 16: Avoid wrapping fields in getters and setters just to be "safe".

line 16 col 7: Avoid wrapping fields in getters and setters just to be "safe".

Fix lib/time_slot_picker.dart. (-0.50 points)

Analysis of lib/time_slot_picker.dart reported 1 hint:

line 74 col 10: Name non-constant identifiers using lowerCamelCase.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-18.63 points)

The package was last published 61 weeks ago.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test