time_range 1.1.0 icon indicating copy to clipboard operation
time_range: ^1.1.0 copied to clipboard

Flutter widget for selecting a time range. You can specify the steps between the hours, time blocks that the range must meet and widget colors.

1.1.0 - 12/12/2022 #

  • Integrate a CI system
  • Thanks @pablojimpas

1.0.3 - 05/07/2022 #

  • Fix error Fix: 'WidgetsBinding’ excludes null
  • Thanks to @dkobia

1.0.2 - 22/10/2021 #

  • Added minimalTimeRange (Could be like 60 minutes - so the first option of the end is 60 minutes after the start)
  • Fixed null pointer when first select end (before selecting any start)
  • Fixed non-visible text when the textsize is too large (Check image)
  • Thanks to @stefanschaller

1.0.1 - 27/09/2021 #

  • Add testing to package. Thanks to @manuelperez96.

1.0.0 - 17/03/2021 #

  • Migrate to null-safety and refactor for best package files organization

0.5.0 - 24/09/2020 #

  • Use devices time display format. Thanks to @matthewtsmith.

0.4.0 - 10/08/2020 #

  • Takes into account the time user has selected and the time block before resetting the end time. Thanks to @ELHorse.

0.3.0 - 11/06/2020 #

  • Add parameters textStyle, activeTextStyle and activeBorderColor

0.2.1 - 04/06/2020 #

  • Fix error updating initialRange

0.2.0 - 04/05/2020 #

  • Modify selected time font weight
  • Update example

0.1.2 - 30/04/2020 #

  • Fix error time button does not fit theme font size

0.1.1 - 29/04/2020 #

  • Update documentation

0.1.0 - 15/04/2020 #

  • Resolve package suggestions

0.0.1 - 13/04/2020 #

  • Initial release
83
likes
120
pub points
92%
popularity

Publisher

verified publisher iconcodigobase.es

Flutter widget for selecting a time range. You can specify the steps between the hours, time blocks that the range must meet and widget colors.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on time_range