tiles 0.3.2

  • README.md
  • Installing
  • Versions
  • 0

Tiles #

Build Status

Component library to declarative programing of UI in webapp based on Dart language.

Docs #

For the beta version of docs, see the wiki.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  tiles: ^0.3.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:tiles/tiles.dart';
  
Version Uploaded Documentation Archive
0.3.2 Jan 30, 2017 Go to the documentation of tiles 0.3.2 Download tiles 0.3.2 archive
0.3.1 May 24, 2016 Go to the documentation of tiles 0.3.1 Download tiles 0.3.1 archive
0.3.0 May 17, 2016 Go to the documentation of tiles 0.3.0 Download tiles 0.3.0 archive
0.2.3 Apr 8, 2016 Go to the documentation of tiles 0.2.3 Download tiles 0.2.3 archive
0.2.2 Feb 1, 2016 Go to the documentation of tiles 0.2.2 Download tiles 0.2.2 archive
0.2.1 Oct 12, 2015 Go to the documentation of tiles 0.2.1 Download tiles 0.2.1 archive
0.2.0+3 Sep 10, 2015 Go to the documentation of tiles 0.2.0+3 Download tiles 0.2.0+3 archive
0.2.0+2 Sep 10, 2015 Go to the documentation of tiles 0.2.0+2 Download tiles 0.2.0+2 archive
0.2.0+1 Jul 29, 2015 Go to the documentation of tiles 0.2.0+1 Download tiles 0.2.0+1 archive
0.2.0 Jul 29, 2015 Go to the documentation of tiles 0.2.0 Download tiles 0.2.0 archive

All 20 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.