themify_flutter 1.0.0

  • Readme
  • Changelog
  • Installing
  • 80

pub package

themify_flutter #

Themify icons for your Flutter apps. All of 353 icons are available to use.

Installation #

First, add file_picker as a dependency in your pubspec.yaml file.

themify_flutter: ^1.0.0

Usage #

Just as any other package, first import it:

import 'package:themify_flutter/themify_flutter.dart';

and then you are all set and ready to use the Icon. For example


You can check the full list of the available icons with its names at the official site.


Getting Started #

For help getting started with Flutter, view our online documentation.

For help on editing plugin code, view the documentation.

[1.0.0] - 2019/05/03 #

  • Initial release of Themify icons for Flutter.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  themify_flutter: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:themify_flutter/themify_flutter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Analysis suggestions

Package not compatible with SDK dart

because of import path [themify_flutter]

Health issues and suggestions

Document public APIs. (-1 points)

354 out of 354 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/themify_flutter.dart.

Run flutter format to format lib/themify_flutter.dart.

Maintenance suggestions

Package is getting outdated. (-16.44 points)

The package was last published 60 weeks ago.

The package description is too short. (-16 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and themify_flutter.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies