texture_atlas_transformer 1.0.1

texture_atlas_transformer #

A transformer to build JSON Atlas files for inclusion in games.

Example pubspec.yaml:

transformers:
  - texture_atlas_transformer:
      output_dir: web/assets/textures
      scale: 0.125
      files:
        flying:
          frames:
            - "web/assets/green_flapper/Transparent PNG/flying/*.png"

Options #

  • output_dir: Output directory to generate files into.
  • scale: Either a num or a Map (ex. {'x': 0.5, 'y': 1.0}). This ratio is applied to every frame.
  • resize: Same as scale; however, each frame is resized to the exact size, instead of being scaled.
  • files: A Map of Strings to atlas definitions.
  • extension: The output image extension. Default: png. Supports jpg, jpeg, gif, and tga.

Atlas Definitions #

  • frames: A List of Strings representing files to be combined. Supports globbing.
  • animations: A Map of Strings to animations.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  texture_atlas_transformer: ^1.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:texture_atlas_transformer/texture_atlas_transformer.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0

Admin