text_to_speech_api 0.1.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 73

text_to_speech_api #

A simple wrapper for Google's Text-To-Spech API. Simply list the available voices and convert your text to a mp3 by providing your API key, language code and voicename.

Usage #

  • add the package as a dependency to your pubspec.yaml file:
dependencies:
  flutter:
    sdk: flutter
  text_to_speeech_api: ^0.0.1
  • Initialize the TextToSpeechService (optional: provide your api key)
TextToSpeechService service = TextToSpeechService('sample api key');
  • List the available voices (no api key required)
await service.availableVoices();
  • Convert your text to a File object (api key required)
File mp3 = await service.textToSpeech(
  text: 'Hello World',
  voiceName: 'de-DE-Wavenet-D',
  audioEncoding: 'MP3',
  languageCode: 'de-DE'
);

[0.0.1] - 2019-02-19 #

  • Initial release.
  • Convert Text to mp3 File
  • Get available Voices

example/lib/main.dart

import 'dart:io';

import 'package:flutter/material.dart';
import 'package:text_to_speech_api/text_to_speech_api.dart';
import 'package:audioplayer/audioplayer.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      theme: ThemeData(
        primarySwatch: Colors.blue,
      ),
      home: MyHomePage(title: 'Text To Speech Example'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  TextToSpeechService _service = TextToSpeechService('Your api key');
  AudioPlayer _audioPlayer = AudioPlayer();

  void _playDemo() async {
    File file = await _service.textToSpeech(text: 'Hello World');
    _audioPlayer.play(file.path, isLocal: true);
  }

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: Center(
        child: Column(
          mainAxisAlignment: MainAxisAlignment.center,
          children: <Widget>[
            Text(
              'Press the play button to speak a demo text.',
            ),
            Text(
              '$_counter',
              style: Theme.of(context).textTheme.display1,
            ),
          ],
        ),
      ),
      floatingActionButton: FloatingActionButton(
        onPressed: _playDemo,
        tooltip: 'Play Demo',
        child: Icon(Icons.add),
      ), // This trailing comma makes auto-formatting nicer for build methods.
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  text_to_speech_api: ^0.1.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:text_to_speech_api/text_to_speech_api.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
57
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
77
Overall:
Weighted score of the above. [more]
73
Learn more about scoring.

We analyzed this package on Apr 8, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.1
  • pana: 0.13.6
  • Flutter: 1.12.13+hotfix.8

Health issues and suggestions

Document public APIs. (-1 points)

13 out of 13 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (path_provider).

Package is getting outdated. (-13.15 points)

The package was last published 59 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
http ^0.12.0+1 0.12.0+4
path_provider ^0.5.0+1 0.5.0+1 1.6.5
Transitive dependencies
async 2.4.1
charcode 1.1.3
collection 1.14.11 1.14.12
http_parser 3.1.4
meta 1.1.8
path 1.6.4
pedantic 1.9.0
sky_engine 0.0.99
source_span 1.7.0
string_scanner 1.0.5
term_glyph 1.1.0
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test