testfairy_flutter 1.0.3

  • README.md
  • Example
  • Installing
  • Versions
  • 49

testfairy_flutter #

DEPRECATED - Here is the new package

1.0.0 #

  • Initial release.


Example SDK App (also includes test cases) #

Demonstrates how to use the TestFairy plugin. Execute flutter run in this folder to see it in action.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  testfairy_flutter: ^1.0.3

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:testfairy_flutter/testfairy_flutter.dart';
Version Uploaded Documentation Archive
1.0.3 Mar 13, 2019 Go to the documentation of testfairy_flutter 1.0.3 Download testfairy_flutter 1.0.3 archive
1.0.2 Mar 13, 2019 Go to the documentation of testfairy_flutter 1.0.2 Download testfairy_flutter 1.0.2 archive
1.0.1 Mar 12, 2019 Go to the documentation of testfairy_flutter 1.0.1 Download testfairy_flutter 1.0.1 archive
1.0.0 Mar 12, 2019 Go to the documentation of testfairy_flutter 1.0.0 Download testfairy_flutter 1.0.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jun 17, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.2
  • pana: 0.12.18
  • Flutter: 1.5.4-hotfix.2


Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

53 out of 53 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Maintenance issues and suggestions

Support latest dependencies. (-5 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8