test_debug is a pub transformer which provides
.debug.html files for dart tests when using
pub serve. These can
be opened in dartium for debug purposes.
test_debug to your pubspec.yaml:
name: test_debug_example dev_dependencies: test: any test_debug: any transformers: # Place test_debug before test/pub_serve to avoid unnecessary generated html files - test_debug: $include: test/**_test.dart - test/pub_serve: $include: test/**_test.dart
There's no real difference. Just make sure to apply all
angular_test specific transformers.
name: test_debug_example dependencies: browser: any angular2: '3.0.0-alpha+1' dev_dependencies: angular_test: '1.0.0-beta+1' test: any test_debug: any transformers: # Run the code generator on the entire package. - angular2/transform/codegen # Run the reflection remover on tests that have AoT enabled. - angular2/transform/reflection_remover: $include: - test/angular_test.dart - test_debug: $include: test/**_test.dart - test/pub_serve: $include: test/**_test.dart
pub serve you can open the debug files in dartium:
Notice that port
8081 is the default port used by
pub serve if a
web/ directory exists. Check the output of
pub serve to see on which port your tests are available.
Add this to your package's pubspec.yaml file:
dependencies: test_debug: ^0.1.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.0||Apr 1, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>= 1.22.0 <2.0.0|